Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!




  • KsciverKsciver Newbie CommonPosts: 2
    Where can I find the full game list, that was the primary reason I would usually use this site.  The massive list on one page with all of the games so I can find what I'll dive into next...
  • ayndreayndre Member UncommonPosts: 10
    Hey. I can't seem to find the button to start a new thread. Is it due to rank, or is that a bug?
  • hyoslvr2hyoslvr2 Member CommonPosts: 1
    I am associated with CRS and use to post articles/Blogs with updates on WWII online usually on a weekly basis. However with your most recent update of MMORPG I have not been able to get in to post some very important information about WWII Online. I have attempted to access my usual link to our admin to no avail. The president of CRS XOOM asked if I could get in touch with you to remedy this.  He too has tried and cant figure out your new format.  When I use our link I get "ERROR 404" .   When I come into MMORPG  the admin for posts is not available.  Could you please look into this?  I have missed several community updates on our game. Thank You 
  • kayser76kayser76 Member UncommonPosts: 3
     Cannot vote on polls
    Necesito el SETUP perfecto para mi próximo PC Gaming, puedes ayudarme en este enlace. Escribe tu setup factible perfecto o lo mejor posible para mi presupuesto para tener el mejor pc gaming! 
  • unleashwowunleashwow Newbie CommonPosts: 3
    i can post xD
  • MightyUncleanMightyUnclean Member EpicPosts: 3,499
    Here's a forum issue:  Your forums are being overrun by spambots.  See above.
  • UgurzuUgurzu Member UncommonPosts: 4
    I can't create new threads. There is no "New thread" button or similar
  • FaileasFaileas Member UncommonPosts: 84
    edited March 10
    Ugurzu said:
    I can't create new threads. There is no "New thread" button or similar
    Same here. I want to be part of the conversation with you guys. I promise I'm not a bot, I promise!  o:)

    Edit: Oof, never mind. Apparently you need to be promoted to the Uncommon rank (next rank above your current) rank to create threads. My bad.

    Post edited by Faileas on
  • dawnrezacdawnrezac Newbie CommonPosts: 1
    MikeB said:
    Hey everyone.

    New forums are live (duh!). Please post any issues or bugs you find here!
    I just purchased Guardians of Ember-Mortal Addition from Wild Tangent, which I activated on Steam. I cannot connect to a server or launch the game at all and do not know how to proceed from here. Any suggestions? I meet all the requirements the game requires. Thanks for any direction.
  • coretex666coretex666 Member EpicPosts: 4,004
    I tried to make a post and when I hit send, I got a captcha pop up window. It asked me to complete the captcha in order to prove I am not a bot.

    However, the window is completely screwed up - part of the text was inside of it, part of the text was just somehow floating in the background unreadable. Also, the window did not contain any captcha to complete.

    What the hell is this? I already gave up on using this site on my mobile phone and now this? This happened on a regular desktop PC.

Sign In or Register to comment.