Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

What a buggy mess

QuizzicalQuizzical Member LegendaryPosts: 24,549
One of the things that you hope for when picking up a game ten years past launch is that the launch problems will be long since fixed and the game will be pretty polished.  I don't know what problems Aion did or didn't have at launch, but the new player experience today is sure a mess.

The game loading screen is accompanied by a weird, screeching sound effect.  I'm not sure what it's supposed to be.  It reminds me of turning on a shower.  I don't think that was the intent behind it.  If fan noise is any indication, that loading screen seems to be the most hardware-intensive part of the game.  It's just a still screen with nothing moving.

Once you get past the loading screen, you get to a window where it wants you to click on stuff, whether to create a new character or enter the game as an old one.  Lots of games do that.  The problem is that clicking on apparent buttons doesn't actually do anything.  Everything is shifted or stretched or something, so that if you point the mouse at some other spot that is not the button you want to click on, it will highlight the button that you do want.  Then you can click and it will have the effect of clicking on that button.  Even though the mouse isn't pointed at it.

Oh, and it wants you to enter a secondary password, probably for account security.  This requires clicking a series of 6-8 buttons to type in a number, with the buttons scrambled randomly each time.  It can't be done from text, but only a mouse, most likely as a way to prevent people from getting accounts stolen even if they get a keylogger.  These buttons don't highlight when you mouse over them.  And to click the button, the mouse isn't supposed to be pointed at the button itself.  It's supposed to be pointed at some other, unlabeled part of the screen.  Clicking a digit makes an asterisk appear, so that you can't see what you clicked.

It appears that the bug is a problem of the window's display resolution not matching what the game thinks it is for purposes of mouse clicking.  You can reach the menu to get into the graphics options at this point, to change your monitor resolution.  If you change it, then everything matches and the mouse subsequently works properly.

Until you reboot the game, that is.  The game doesn't save the monitor resolution that you last used.  Rather, it reverts it to this broken, default state.  Going through and clicking on buttons by pointing the mouse somewhere else to click it has to be redone every time the game is launched before it will be functional.  No, seriously.  I'm not making this up.

It's fortunate that someone thought to put the graphics options menu at the intro screen.  Some games don't let you access settings until after you've played through the tutorial.  In most games, that's just a stupid nuisance.  In Aion, that would have made the game literally unplayable.

So after solving that puzzle just to access the game, I played through the intro zone, to reach level 10.  Thus far, mobs barely deal damage.  I'm hoping that the combat gets better at higher levels, and only the tutorial intentionally makes combat trivial so that players don't get stuck on it.

Thus far, nearly all of my time in the game proper has been trying to figure out what to do.  A lot of things say, go talk to so and so, or go pick up this or that item.  But they don't say where.  Sometimes, it is labeled on a map.  If you need to kill particular mobs, they'll be marked when you're close to them.  But a lot of things are labeled on a map with a lot of different icons, so that it isn't clear which icon is the one that you're actually supposed to care about.  And sometimes, where you're supposed to go isn't even labeled, and you're apparently supposed to randomly guess.

Nearly all of the combat was in one dungeon, which I only had to fight through four times before the game would let me move on.  I think it was NCSoft's intent that players fight through it once, not four times.  It doesn't have the obvious, dungeon repeat quest mechanics of a game like Elsword or Kritika.  But see the title of this thread.

Basically, you get various quests as you go through the dungeon to do things in it, which I did.  One quest was to kill the boss of the dungeon, so I did.  After that, a portal opens for you to leave the dungeon, which warps you to the other side of the zone.  No problem, a lot of games have portals to let you leave a dungeon rather than having to manually run back to the beginning.

Except that I wasn't supposed to leave the dungeon.  The campaign then required me to go pick up something that was in the dungeon, but didn't tell me where.  I had to look it up on the wiki to find out where it was.  So I went back all the way across the zone and picked up the item, and then the campaign asked me to kill the boss of the dungeon.  So I went back to where the boss was.

Just shy of the boss room, I fell through the floor and instantly died.  That respawns you back at the start of the dungeon.  So I had to fight my way through it a third time.  Also, mobs respawn, so this wasn't just run through the now cleared area.

Once I reached the boss, the boss was gone, because I had already killed him.  But I can't just dismiss this quest to kill the end boss and drop it as it's the main campaign line.  You literally can't progress any further in the game until you complete it.  The game won't let you leave the tutorial area until then.

So, I took the portal to leave the dungeon rather than fighting my way through it backward, went all the way across the starter zone again, and reset the dungeon.  I fought my way through it for the fourth time and killed the boss a second time.  This time, it actually worked, and I was able to move on.

That doesn't necessarily mean that the game is bad.  It sure does mean that the tutorial is badly designed, though.  If a game gives you quests A and B simultaneously and no indication that you're supposed to do A before B, a player figuring out how to do B before figuring out how to do A (as it was more clearly labeled what to do) shouldn't mean having to fight through a dungeon four (!) times instead of one.  I think that I could probably do it in one pass now that I know how--now that I've gotten past that region entirely.

Game performance was odd.  The game seems to cap frame rates at 30 frames per second for some inexplicable reason.  As 30 doesn't divide my monitor refresh rate, that's going to mean some unnecessary judder.  Animations did otherwise seem decently smooth in the game proper, though.  The cut scenes sure didn't, as those were really blocky, low res stuff that ran at 2 frames per second, which hurt to look at.

The controls seem to be designed for heavy mouse usage.  Not just mouse as opposed to controller, but mouse as opposed to keyboard, even.  Also, the game isn't smart enough to realize that if you assign one function to Space and another to Ctrl+Space, then actually press Ctrl+Space, you only want the latter function and not the former.  It decides to execute both, even if you press Ctrl before Space and release Ctrl after Space, so that Space is never touched without Ctrl.  That's really going to be a problem for trying to use skills with various combinations of buttons.

I'll probably play somewhat further.  I haven't yet run into anything that conclusively demonstrates that the whole game is bad, as opposed to this or that small portion of it.  But I'm pretty sure that it's never going to be comfortable to play on a controller.


  • skeaserskeaser Member RarePosts: 4,163
    I feel like I am responsible for sending you into this mess from the hotbar discussion the other day. I tried Aion again about a year ago, I'm sorry that I ended up sending anyone else that way.
    Sig so that badges don't eat my posts.

  • Jamar870Jamar870 Member UncommonPosts: 555
    I'll have to check in on my toons I left there.

Sign In or Register to comment.