Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

M.2 SSD dead on arrival?

QuizzicalQuizzical Member LegendaryPosts: 24,851
I mentioned this in another thread, but I'd like some troubleshooting help in case I'm missing something before I return an SSD as being dead on arrival.

I have a Mushkin Pilot 1 TB SSD and a Gigabyte X470 Aorus Ultra Gaming motherboard.  I've assembled the computer and everything seems to work except for the SSD.  In the BIOS, the Mushkin Pilot SSD does not appear in the boot priority menu, but a SATA SSD that I put into the system as a way to transfer data from my old computer does.  Similarly, when I boot to a Windows USB stick to install Windows 10, the SATA SSD is on the menu of available options, but the Mushkin Pilot SSD is not.  The same happens when I run DxDiag from within Windows, though I'm not sure off hand if that will detect an unformatted drive.

I had never installed an M.2 SSD before.  My understanding of it is that you just stick in in the M.2 slot on the motherboard, insert a screw in the notch at the end opposite the M.2 slot to hold it in place, and that's it.  Both power and data come through the M.2 slot rather than needing a separate cable from the power supply.  Obviously, the drive will need to be formatted before you can use it, but that should be enough for the BIOS to find it and Windows to be able to install on it.

My motherboard has two M.2 slots:  one is a PCI Express 3.0 x4 slot using PCI Express lanes coming off of the CPU socket.  The other is a PCI Express 3.0 x2 slot using PCI Express lanes coming off of the chipset.  The former certainly doesn't have its lanes shared with anything else on the motherboard, as AMD's platform has a dedicated PCI Express 3.0 x4 connection coming off of the CPU socket intended for an M.2 SSD.  I don't think that the latter has lanes shared with anything else, either.  Regardless, the only other PCI Express device in the system is a discrete video card that uses the PCI Express 3.0 x16 slot that has its own dedicated lanes coming off of the CPU socket.

I have tried putting the M.2 SSD into both of the M.2 slots, then going into the BIOS.  In neither case did the BIOS recognize the existence of the M.2 SSD.

There is no option in the BIOS to enable or disable the M.2 slots.  I've looked repeatedly, both in the BIOS itself and in the motherboard manual.  I assume that means that they are always enabled.

There is no thin plastic sheet covering the M.2 connector on the SSD, nor the M.2 slot on the motherboard.  I've explicitly checked both, just in case I missed something that was blocking a connection.

When I put the SSD into either M.2 slot, it doesn't feel very snug.  It does rise up above being level with the motherboard, which I've read is typical.  But it's not a tight fit like SATA, USB, or DisplayPort ports are.  Rather, the SSD can readily wiggle, both in the horizontal and vertical directions.  It has to be able to move in the vertical direction or else it wouldn't be possible to push it down to insert a screw.  How easily it wiggles in the horizontal direction is a little disconcerting, but might be completely normal.  That is true when I insert it into either M.2 slot on the motherboard.

I have not specifically installed any M.2 drivers or BIOS updates.  An X470 motherboard is very recent, and I assume that it already comes with M.2 support.  I did catch a note in the documentation about needing a future update if you want multiple M.2 SSDs in RAID, but I think that only applies to using RAID.  I'm not using any type of RAID.

In principle, if you have only one SSD and only one M.2 slot, and it doesn't work, either part could be the defective one.   With only one SSD and two M.2 slots, I'm guessing that it's more likely that the SSD is defective.

Does anyone see anything that I'm missing that would fix the problem?


  • MMOman101MMOman101 Member UncommonPosts: 1,779
    edited August 2018
    Edit, he mailed it back already. 
    Post edited by MMOman101 on

    “It's unwise to pay too much, but it's worse to pay too little. When you pay too much, you lose a little money - that's all. When you pay too little, you sometimes lose everything, because the thing you bought was incapable of doing the thing it was bought to do. The common law of business balance prohibits paying a little and getting a lot - it can't be done. If you deal with the lowest bidder, it is well to add something for the risk you run, and if you do that you will have enough to pay for something better.”

    --John Ruskin

  • MoiraeMoirae Member RarePosts: 3,318
    I had a 3 TB HD die on me three days after getting it. I took it to geeksquad to have them plug it in and check. It didn't cost me anything and took them only a minute to say it was dead. Personally, I already knew it, I just needed the verification. It's the only time I've used a tech company to check something out for me in 20 years. 
Sign In or Register to comment.