Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

just started my trial

arakkunearakkune Member UncommonPosts: 24

Hello there. I've played ws in the beta and didnt rly like it but since the f2p anouncement i thought mb i should try it again and i think i was really biased when i left the game because from what i see now this game is srsly one of the best and i liked the trial so much in a few days ill prbbly buy the game. I have only 1 issue i seem to be getting  some fps drops when most of the time the game is at 70 fps and then suddenly it went to 28 at a more dense area im on a laptop but it doesnt seem to get hot or throttle soo can someone help if there are some settings tweaks ^^

Comments

  • AeroangelAeroangel Member UncommonPosts: 493
    The last laptop I had, had similar issues that got progressively worse, but for a long time I "fixed" it by underclocking the graphics card and running at lower settings. Either way try googling your specific laptop brand and the frame rate issue.

    --------------------------
    Playing:
    FFXIV, TERA, LoL, and HoTS
    My Rig:
    GPU: GeForce GTX 770, CPU: i7-4790K, Memory: 16 GB RAM

  • ButeoRegalisButeoRegalis Member UncommonPosts: 594

    Lots of possible reasons. Some areas are know to be problematic for anyone, there were some issues with AMD processors, and other things going on.

    Best might be to be more specific about the problem and your PC specs.

     

    You can also try to post here:

    https://forums.wildstar-online.com/forums/index.php?/forum/101-tech-help/

    image

  • arakkunearakkune Member UncommonPosts: 24
    well its a lenovo y50 i7 4720HQ 3,6ghz nvidia geforce 960M and 16gb ram its the first time i have problems like that with a game and i thought it might not be that well optimised but who knows LOL
Sign In or Register to comment.