Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fun Video of Riot Playing CU!

dantheman13dantheman13 Member UncommonPosts: 55

Well, sort of.  My GW2 guild, Team Riot (teamriot.org) is a small gank guild in Tier 1.  We jumped into the CU engine/network tech demo late at night and actually had a blast!

http://www.twitch.tv/aodhnitola/b/397558988

Comments

  • Morian79Morian79 Member Posts: 18

    Is that a new version?

    Where can I download it?

  • MkilbrideMkilbride Member UncommonPosts: 643

    What's your system?

     

    When I was playing with 118 people I was getting 1400-2000

     

    You seem to be @ 100-200.

    Help get Camelot Unchained made, a old-school MMORPG, with no hand holding!

    http://www.kickstarter.com/projects/13861848/camelot-unchained

  • Morian79Morian79 Member Posts: 18
    Originally posted by Ziftylrhavic
    http://camelotunchained.com/en/engineeringtest/

    Thanks!

  • sk8chalifsk8chalif Member UncommonPosts: 662
    do u have to be part of the kickstarter to be able to login?

    image
    ~The only opinion that matters is your own.Everything else is just advice,~

  • Niix_OzekNiix_Ozek Member Posts: 397
    Was the glitching part of your stream?

    Ozek - DAOC
    Niix - Other games that sucked

  • EdanyEdany Member UncommonPosts: 179
    @sk8chalif - Not that I know of, but it helps. That's where the links to the client are distributed from. 
  • GKermichilGKermichil Member Posts: 32
    Originally posted by Mkilbride

    What's your system?

     

    When I was playing with 118 people I was getting 1400-2000

     

    You seem to be @ 100-200.

    Also, make sure your drivers are up to date.  I logged in the first time and was getting 50-60.  Updated my drivers and smoothly get 700-900.

    image

  • dantheman13dantheman13 Member UncommonPosts: 55
    Originally posted by Niix_Ozek
    Was the glitching part of your stream?

    I think that the choppiness is his stream.  There was some rubber banding especially from our friend who was lagging.

  • AodhNitolaAodhNitola Member Posts: 1
    The fps was very low at the start because I was still running GW2 in the background. I closed it a bit into the stream and the frames jumped to about ~500. One of our players was lagging on his end and that was the teleporting Viking. The game was playing pretty smooth on my end. My specs are on the channel though, www.twitch.tv/aodhnitola
Sign In or Register to comment.