Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Dragon Age game sweepstakes

nilrem20nilrem20 Member UncommonPosts: 4

I have not been able to open the link to the Dragon Age sweepstakes that started 11/9/09 it has really saddened me because i have been following this game for a while and it looks interesting. am i the only one with this issue? it shows the words there the link would be but it is grayed out.


  • cukimungacukimunga Member UncommonPosts: 2,258

    Nope it worked for me when I entered the contest and I just clicked on it right now and worked again.   Sorry you're having troubles with it.

  • fyerwallfyerwall Member UncommonPosts: 3,240

    Is it somehow tied to post counts maybe?

    Try making five posts and see if that helps...

    There are 3 types of people in the world.
    1.) Those who make things happen
    2.) Those who watch things happen
    3.) And those who wonder "What the %#*& just happened?!"

  • alabama344alabama344 Member Posts: 6

    Hmm, I've been having this issue also, will try the posts

  • nilrem20nilrem20 Member UncommonPosts: 4

    odd, i have never heard of it being tied to posts and have been a member for a couple of years now.

  • nilrem20nilrem20 Member UncommonPosts: 4

    is it possible to get a moderators reply? there was an issue a while back but it was affecting all members and they were aware of it and fixed the issue and credited everyone who logged on with credits to the sweepstakes as if we had.

  • nilrem20nilrem20 Member UncommonPosts: 4

    ok now it works after 3 posts, i didnt check earlier and dont want to spam even my own posting for 5 posts total. it would have been nice to know i would have had to have those posts. if i had i wouldnt have missed all these days on extra entries. any way i can get them back. i know there servers record when members log in and thats all i ask for.

Sign In or Register to comment.