Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fatal Error message. Please help

oakthornnoakthornn Member UncommonPosts: 863



 I just reopened my EQ2 account a week ago, and so far I've been playing alright with no problems until today. Well, last night there were some very serious lag issues in Neriak, not to mention a couple times my computer froze up when trying to zone. I understand this has been a problem since the new Expansion came out, especially on AB, but what happened today was the first. Heres the ERROR and explanation of what happened.

First, I was on my Brigand in EFP. I then tried to zone to WFP when my pc froze up. I turn the pc off, reboot, log back in and now I'm in WFP. After running to the INN to talk with Izzay, this fatal error message popped up and EQ2 was forced to shutdown. Here's what the message says, word for word.


EQ2 has detected an unrecoverable error and must shut down. <verify> E:LIVEEQ2frameworkcoredevicessrcDirextx9Render Devices.cpp (1032): Failed to create D3D Device for NVIDIA GeForce 8800GTS

 Now, keep in mind I've been running the game on my 8800 GTS for about a week now, and this is the first time I encountered this problem.

Initially I thought it was a DX9 Problem. So I basically redownloaded it and that did not work. I tried logging back into EQ2 and the same message appeared right away..  Any idea on what I should do?


*Edit* Here are my computer specs

AMD Athlon X2 4600 Processor

NVIDIA 8800 GTS Vid Card

2 Gig DDR800 Duel Channel RAM

Asus M2N32 SLI 590 Deluxe Motherboard

Rallithon Oakthornn
(Retired Heirophant of the 60th season)


  • quaikyquaiky Member Posts: 566

    i had this message sometimes before on my second computer after eq2 game crashes. rebooting the computer did allways fix it for me  i think it has something to do with the crash and directx that cannot initialise the gfx card after the crash.

  • MoiraeMoirae Member RarePosts: 3,318

    There might be something wrong with your driver. Have you gone to the web site to download any updates for the driver? That will probably help.

  • oakthornnoakthornn Member UncommonPosts: 863

    I did the initial reboot, this allowed me to get back into the game, but once I tried to zone, the same thing happened, only this time, the "(D3DERR OUT OF VIDEO MEMORY) message appeared. So i went and completely uninstalled EQ2 and dx9, and reinstalled them all. The same problem is there.

    And yes, I have the latest NVIDIA drivers for my card.

    Rallithon Oakthornn
    (Retired Heirophant of the 60th season)

  • Darklite1Darklite1 Member Posts: 5



    First off this is a fairly common problem. Update your video driver and your sound drivers. Then update Directx. Reboot and log in. Before you game in. run a full file scan in EQ2 to verify. It should work fine from there.


    Good Luck.


  • oakthornnoakthornn Member UncommonPosts: 863

    Thanks for the help :) I redownloaded everything, including the newest sound card drivers and so far all is working well.

    I'm having alot of fun since returning. I really like the new racial traits just added for all races, and timorous deep is pretty cool. Definitely glad I chose to come back to the franchise that started my MMO gaming addiction.

    Rallithon Oakthornn
    (Retired Heirophant of the 60th season)

Sign In or Register to comment.