Quantcast

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

AVX Requirement kills the beta for some folks

TillerTiller Member EpicPosts: 8,934
edited June 2018 in The Crew 2
Well the first major beta screw up is happening. It seems that Advanced Vector Extensions tied to CPU  is preventing some players from being able to load the game at all if their CPU doesn't support it.


SWG Bloodfin vet
Elder Jedi/Elder Bounty Hunter
 
Sign In or Register to comment.