Quantcast

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

PC problem

chondro69chondro69 Member CommonPosts: 53

So I'll try and expain this the best I can. I have a gaming laptop and I can post specs later if needed.  For some reason When I try and play games like Tera or neverwinter or even Blackops ect I have terrible picture and really bad graphics and lag... When I first got this PC I never had any issues running these games on max setting or close to it with 1920x 1080 res.... Then I decided to plug my laptop into my TV for fun and I noticed when I do that I can then run the games on max settings without any lag and games look amazing again! I don't understand whats going on... When I look at my display settings on my laptop It shows the intergrated video card but when I hook my laptop up to my tv it shows my Gforce m555 card.... not sure how to fix this so I can game on my laptop without using my HDtv. Im not very computer savy so excuse me if I get the terminology wrong or w/e

I tried to disable the intergrated card but then I had no display and had to reboot my pc to fix it.

Thanks

Comments

  • chondro69chondro69 Member CommonPosts: 53
    Figured out what the problem is... some games my default will run the integrated video card and other games runs my geforce! Explains why I have no issues with some games and other games I cant run at all. Now I need to figure how to disable the integrated video from within bios?? Right clicking and disabled from within advance settings but that didnt work. Can anyone help?
  • sushimeessushimees Member Posts: 489

    Tell us your laptop name or specs. Otherwise, you can try to Google your issue. I've come across this problem multiple times and usually it has an easy solution.

     

    image
    image

  • chondro69chondro69 Member CommonPosts: 53

    MOTHERBOARD: Phoenix Securecore Tiano

    XPS L702x

    Intel Core i7-2670 QM CPU@ 2.20 GHZ

    8.00 GB RAM

    64 bit OS

    Nvidia Geforce GT 555m video card

    Hope this helps =( I can't seem to find any options in the BIOS to disable the onboard video card.. Not sure what im looking at really. Also When I disable it from within device manager my screen turns black and I cant do anything just have to reboot laptop but then it turns on the onboard video card again.

     

  • syntax42syntax42 Member UncommonPosts: 1,378

    The primary method of turning off your integrated graphics would be in the BIOS on desktop systems.  I'm not sure if you'll find it in the BIOS on your laptop.

     

    One possible solution might be to hook your laptop up to a TV, disable the onboard graphics using Device Manager, then reboot and unplug from the TV while the computer is shutting down.  Windows might be reverting your changes after a hard reset like you describe.

     

    There might be a setting in the display properties, or in the NVIDIA/ATI control panel.  I've never had a system with more than one graphics card to worry about, so this issue is a bit beyond my knowledge.

  • QuizzicalQuizzical Member LegendaryPosts: 22,206

    If you could disable the integrated graphics, it would leave the laptop with no way to communicate with the monitor.  That would mean that the laptop wouldn't work, period.

    The way that discrete switchable graphics works is that the integrated graphics is always what communicates with the monitor.  When the discrete video card is turned off, that's about all that happens for graphics.  When the discrete video card is on, data is passed to the discrete video card to render a frame, and then the completed framebuffer is copied from the discrete video card to the integrated graphics, which is then used to display it on the monitor.

    The reason that I recommend that people not buy a discrete video card that isn't all that much faster than integrated graphics is that it can give you entire new classes of problems without offering the performance to justify it.  Most likely, you're seeing the discrete video card fail to kick in when it ought to, but rather, having the game run on the integrated graphics.  You can check the Nvidia control panel to see if there's a way to force the video card on for the particular game.

  • RidelynnRidelynn Member EpicPosts: 7,074

    There should be an exclusion list in the driver to force the card to either integrated or discrete.


    Please make a right click on the desktop. You will get a new menu. Now please select "nvidia control panel".
    In the "nvidia control panel" you need to select "Manage 3D Settings" Please go over to "Program Settings".
    Now you will have to "Add" the simulation you would like to be started with the nvidia card. Therefore you will have to add the application file of your simulation - e.g. "aerofly5.exe". If there is file named "flyrun.exe", you may add this,too.
    Instead of global settings you now need to change it to "NVIDIA high-performance processor".
    To finish that configuration you just need to click on save. Now you are able to start the simulation using the nvidia processor.
  • jdnewelljdnewell Member UncommonPosts: 2,237

    I have an AMD laptop with the switchable graphics.

    I get a pop up whenever I launch a new program ( game in this case ) asking for high or low graphics performance. Or I can go into CCC and assign it there. I imagine something similar with nvidia under the control panel

  • drbaltazardrbaltazar Member UncommonPosts: 7,856
    You can disable integrated and use only the nvidia .press delete at start up to access bios and find the GPU .your integrated will be the one with memery lowest being 32.the other will probably be saying pcie or such .
    As for your issue .you are probably set to HDMI .I don't know what the onboard screen use but I am pretty sure it won't be HDMI external.go in GPu and find reset option .this should fix your issue(don't forget to restart.
  • chondro69chondro69 Member CommonPosts: 53
    Originally posted by Ridelynn

    There should be an exclusion list in the driver to force the card to either integrated or discrete.

     


    Please make a right click on the desktop. You will get a new menu. Now please select "nvidia control panel".
    In the "nvidia control panel" you need to select "Manage 3D Settings" Please go over to "Program Settings".
    Now you will have to "Add" the simulation you would like to be started with the nvidia card. Therefore you will have to add the application file of your simulation - e.g. "aerofly5.exe". If there is file named "flyrun.exe", you may add this,too.
    Instead of global settings you now need to change it to "NVIDIA high-performance processor".
    To finish that configuration you just need to click on save. Now you are able to start the simulation using the nvidia processor.

     

    This seems to have worked! yay =)

     

  • chondro69chondro69 Member CommonPosts: 53

    Thank you all very much for your input! I'm very thankful for a forums such as this to get help

    Thank you again

  • MothanosMothanos Member UncommonPosts: 1,910

    Download Hardware Info 64 and check your videocards specs, i had a problem once where my videocard woulnt use more then the lower clocking speed.
    Like when you put your pc / laptop into sleep mode.

    Check if your GPU use its full potential when playing.

Sign In or Register to comment.