Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

*Video* Follow-Up Guide For Enhancing Graphics and Performance in SWTOR(Sorry still Nvidia Only)

This is a follow-up for this post http://www.mmorpg.com/discussion2.cfm/thread/337788/page/1

 

I spent many hours trying as many settings as possible to get my system to run well and look a lot better than anything the in-game settings would allow. So this is my guide and I'm sure as I play with more things it will change but I'm hoping this helps some people out. Let me know if you have any questions or suggestions about graphical tweaks or settings in this game!

 

Also wanted to note I didn't mention fxaa in the guide I found the 295.18 drivers unstable so I went back to the 290.53 beta drivers instead which don't allow fxaa to be toggled on like the 295 series. I have tried the injectors but found they don't work well or even look very good in this game.

 

Oh and sorry for the monotone just what I was born with.. heh..

http://www.youtube.com/watch?v=3yQmg9HOKxA&feature=youtu.be

 

*UPDATE 1*

I'm going to post an update with my INI tweaks when I get the chance but just so everyone knows SSAA in this game is not really worth it unless you have dual 580s or 590s.. I have done more tests and found 8xQ(MSAA) + 4X transparency offers almost the exact same image quality with almost half the gpu usage as 8xS(1x2 + 4xMSAA) just for reference with my settings in the video I was at about 50-70% gpu usage on both gpus. With my new 8xQ + 4x Transperancy SS I hardly break 40% usage and it allows me to use shadows and grass if I choose to.

Comments

  • herculeshercules Member UncommonPosts: 4,919

    Or maybe BW can justify the $125m and actually fix the bogus engine they bought  if its even possible.

  • sanosukexsanosukex Member Posts: 1,836

    Originally posted by hercules

    Or maybe BW can justify the $125m and actually fix the bogus engine they bought  if its even possible.

    doubtfull but I spent a good amount of money on my rig I might as well utilize it best I can.

  • Zookz1Zookz1 Member Posts: 629

    i5 2500k 3.3 GHz

    8 GB DDR3 1600

    AMD HD 6770 1 GB

     

    All drivers are up to date. Liquid cooling, and a 700 watt PSU. I fail to see any reason why my comupter shouldn't blow this game out of the water, but I've seen as low as 15 FPS in the Aleraan WZ, and the wost part is that I've literally seen my CPU & GPU @ 20% utilization. I have no bloathware, and I keep everything as clean as possible, but nothing I do seems to have much of an impact. I've seen reports of much higher end machines than mine experiencing similar issues.

     

    Bioware chalks it up to low end systems, but according to the reccomended system requirements, I am WELL above them yet still have less than stellar performance in PVP. In PVE, everything is fine, but in PVP (Alderaan specifically) and large Ilum battles, my machines runs like it's 10 years old. I've about had my fill of performance problems with SWTOR.

  • select20select20 Member Posts: 130

    Originally posted by Zookz1

    i5 2500k 3.3 GHz

    8 GB DDR3 1600

    AMD HD 6770 1 GB

     

    All drivers are up to date. Liquid cooling, and a 700 watt PSU. I fail to see any reason why my comupter shouldn't blow this game out of the water, but I've seen as low as 15 FPS in the Aleraan WZ, and the wost part is that I've literally seen my CPU & GPU @ 20% utilization. I have no bloathware, and I keep everything as clean as possible, but nothing I do seems to have much of an impact. I've seen reports of much higher end machines than mine experiencing similar issues.

     

    Bioware chalks it up to low end systems, but according to the reccomended system requirements, I am WELL above them yet still have less than stellar performance in PVP. In PVE, everything is fine, but in PVP (Alderaan specifically) and large Ilum battles, my machines runs like it's 10 years old. I've about had my fill of performance problems with SWTOR.

    I have exact same specs as you accept my Prosessor  is a i7-860 2.8ghz. I have never seen my fps drop below 30 on max settings. Something is wrong with your system or your a hater.

     

    It must be an Nvidia thing. I say blame them for not updating their drivers. My friend has a Gforce 560ti, which should run a ton better than my 6770hd 1gb. If he doesn't turn his shadows competely off, he's in the low 20's and teens.

    "Life is 10% of what happens to you and 90% of how you react to it."

  • tixylixtixylix Member UncommonPosts: 1,288

    Why does this need a guide? Anyone with half a brain knows all this stuff already.

  • sanosukexsanosukex Member Posts: 1,836

    Originally posted by tixylix

    Why does this need a guide? Anyone with half a brain knows all this stuff already.

    most people i talk to ingame use all ingame settings.. most people I talk to don't even have nvidia inspector and not to mention  i get private messages all the time about this stuff so no I'd say most people don't know this stuff

  • drbaltazardrbaltazar Member UncommonPosts: 7,856

    Originally posted by Zookz1

    i5 2500k 3.3 GHz

    8 GB DDR3 1600

    AMD HD 6770 1 GB

     

    All drivers are up to date. Liquid cooling, and a 700 watt PSU. I fail to see any reason why my comupter shouldn't blow this game out of the water, but I've seen as low as 15 FPS in the Aleraan WZ, and the wost part is that I've literally seen my CPU & GPU @ 20% utilization. I have no bloathware, and I keep everything as clean as possible, but nothing I do seems to have much of an impact. I've seen reports of much higher end machines than mine experiencing similar issues.

     

    Bioware chalks it up to low end systems, but according to the reccomended system requirements, I am WELL above them yet still have less than stellar performance in PVP. In PVE, everything is fine, but in PVP (Alderaan specifically) and large Ilum battles, my machines runs like it's 10 years old. I've about had my fill of performance problems with SWTOR.

    we re all like this 30% computer utilisation ,for some reason something is bugged somewhere.like i am speaking english to a server that speak mandarin so now the server has to translate once done the server doesnt understand the translation so we re all considered hacker so the security counter mesure throttle everything it is at bw end .and most got fed up by the situation.

    same thing happen to me when i dont update my security mse throttle everything till i correct the situation .the trouble with swtor is this:engineer say:there is no problem, what problem?(india accent)

  • sanosukexsanosukex Member Posts: 1,836

    Originally posted by drbaltazar

    Originally posted by Zookz1

    i5 2500k 3.3 GHz

    8 GB DDR3 1600

    AMD HD 6770 1 GB

     

    All drivers are up to date. Liquid cooling, and a 700 watt PSU. I fail to see any reason why my comupter shouldn't blow this game out of the water, but I've seen as low as 15 FPS in the Aleraan WZ, and the wost part is that I've literally seen my CPU & GPU @ 20% utilization. I have no bloathware, and I keep everything as clean as possible, but nothing I do seems to have much of an impact. I've seen reports of much higher end machines than mine experiencing similar issues.

     

    Bioware chalks it up to low end systems, but according to the reccomended system requirements, I am WELL above them yet still have less than stellar performance in PVP. In PVE, everything is fine, but in PVP (Alderaan specifically) and large Ilum battles, my machines runs like it's 10 years old. I've about had my fill of performance problems with SWTOR.

    we re all like this 30% computer utilisation ,for some reason something is bugged somewhere.like i am speaking english to a server that speak mandarin so now the server has to translate once done the server doesnt understand the translation so we re all considered hacker so the security counter mesure throttle everything it is at bw end .and most got fed up by the situation.

    same thing happen to me when i dont update my security mse throttle everything till i correct the situation .the trouble with swtor is this:engineer say:there is no problem, what problem?(india accent)

    ill test my cpu usage and let you guys know what mines at I usually only have looked at my gpu which depending on how I set my AA settings I can easily hit 100% gpu usage. Any 2x2 SSAA or even 2x SGSSAA will shoot my gpu usage to 100% on both gpus

  • syntax42syntax42 Member UncommonPosts: 1,378

    Has anyone here checked your anit-virus settings?  Many on-demand scanners can cause serious issues with game performance.  Most anti-virus programs let you turn it off for specific programs.

     

    I have not seen any of the performance issues described here.  I'm running a GTX260 with 266.58 drivers (old, I know) and a Core2 Duo and I get 25-50 fps all the time at 1600x1200.  I have shadows turned off because I think their shadow engine looks ugly.  I don't PvP, so maybe that is why I haven't seen the issue.

  • sanosukexsanosukex Member Posts: 1,836

    Originally posted by syntax42

    Has anyone here checked your anit-virus settings?  Many on-demand scanners can cause serious issues with game performance.  Most anti-virus programs let you turn it off for specific programs.

     

    I have not seen any of the performance issues described here.  I'm running a GTX260 with 266.58 drivers (old, I know) and a Core2 Duo and I get 25-50 fps all the time at 1600x1200.  I have shadows turned off because I think their shadow engine looks ugly.  I don't PvP, so maybe that is why I haven't seen the issue.

    I have heard this could be an issue with certain ones especially ones like norton or mcafee(people still use these?).. I use MSE and honestly havent had an issue with it on.. but have tried it off made no difference...

  • sanosukexsanosukex Member Posts: 1,836

    Originally posted by drbaltazar

    we re all like this 30% computer utilisation ,for some reason something is bugged somewhere.like i am speaking english to a server that speak mandarin so now the server has to translate once done the server doesnt understand the translation so we re all considered hacker so the security counter mesure throttle everything it is at bw end .and most got fed up by the situation.

    same thing happen to me when i dont update my security mse throttle everything till i correct the situation .the trouble with swtor is this:engineer say:there is no problem, what problem?(india accent)

    yea just did some tests on my cpu usage it never went about 10% doesn't seem right to me.. I even have pre-rendered frames at 8 also(although i suspect it really does'nt work in this game)

  • KalmarthKalmarth Member Posts: 443

    Many thanks for the Great write up, we need more like you on the forums

  • sanosukexsanosukex Member Posts: 1,836

    Originally posted by Kalmarth

    Many thanks for the Great write up, we need more like you on the forums

    I'm sure many here would disagree with that statement :P

  • RavenspenRavenspen Member UncommonPosts: 104

    You seem to be correct about CPU load.  I'm running about the max possible Nvidia settings and still CPU is pegged at 20%.  GPU wise I'm holding steady at about 65% on the GPUS. 



    Looks like the game's also only using about 2Gb of physical memory so it's a 32 bit program presumably without LAA. 

    I don't normally monitor cpu/ram loads being more focused on the GPU loads and temps when optimizing, but the CPU sure isn't working hardly at all.

    The 6770 is basicly comprable to an Nvidia 460.  It still isn't a bad card though 15fps seems really low for it.  I wonder if you could try turning off AA in game and forcing it on in Catalyst.  I know that the game has problems with AA and some AMD cards.  If you haven't already turn shadows off.

    I found a link with a similar setup though his is a M version so presumably inferior to yours.  I'm not as familiar with ATI cards.  I suspect your performance is about the same.  He indicates

    http://www.swtor.com/community/showthread.php?t=97701

Sign In or Register to comment.