Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can't log in to play this game.

whilanwhilan Member UncommonPosts: 3,472

Okay as i'm in between MMOs i'm out trying others to see what will hold me over for the next...well next couple of months.  Tried to log into the game with the accurate user name and password and was told my account couldn't be accessed.

Thought it was weird because i had just changed my password recently.

Anyway, i tried to log into my gpotato account, only to get an internal error message.  I got this about a week ago so i figured. Hey internal it's their end they will fix it. Except that was a week ago and i still can't log in to either the game or my account.

So i guess what i'm asking is two fold.

First is did anyone else encounter this and if so did you fix it and how?

Help me Bioware, you're my only hope.

Is ToR going to be good? Dude it's Bioware making a freaking star wars game, all signs point to awesome. -G4tv MMo report.



  • mamildormamildor Member Posts: 18

    Same happened to me. I just made a new account and its working fine now.

Sign In or Register to comment.