Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

ATI Drivers 11.1 and Rift

gatherisgatheris Member UncommonPosts: 1,016

so, anyone know if this fixes the display issues with the game or is rolling back to an earlier version the only solution?

if not, which version actually works for the 5870?

 

thanks

image

Comments

  • IzorkIzork Member UncommonPosts: 381

    Originally posted by gatheris

    so, anyone know if this fixes the display issues with the game or is rolling back to an earlier version the only solution?

    if not, which version actually works for the 5870?

     

    thanks

    As far as I remember, I recall reading that there is some fixes for the ATI cards, in Beta 6 patch notes :=)

  • gatherisgatheris Member UncommonPosts: 1,016

    thanks

    did a skim of the patch notes - guess i'll have to actually read them (or just see what happens when i try to get into the game)

    image

  • SeffrenSeffren Member Posts: 743

    Originally posted by gatheris

    so, anyone know if this fixes the display issues with the game or is rolling back to an earlier version the only solution?

    if not, which version actually works for the 5870?

     

    thanks

    What diplay issues do you have?

  • jdnewelljdnewell Member UncommonPosts: 2,235

    I personally rolled back to 10.9 after trying last beta with 11.1 and not being able to see my toon at character select screen.

    10.9 runs fine with no issues at all for me, using a sapphire toxic edition 5850 1gb version

  • tsuktstsukts Member Posts: 164

    I have no issues with ATI and rift and i got 2x 5770 1gb in.

    image

  • SeffrenSeffren Member Posts: 743

    Originally posted by jdnewell

    I personally rolled back to 10.9 after trying last beta with 11.1 and not being able to see my toon at character select screen.

    10.9 runs fine with no issues at all for me, using a sapphire toxic edition 5850 1gb version

    During last beta I also had this issue, but I don't think it was related to 11.1 since it went away after the first patch.

    Edit: I am using a 5970, so maybe that could be it tbh.

  • VosperVosper Member UncommonPosts: 57

    Currently using 10.12 (I know, old) on a 5870 with no troubles last beta.  Previously, in beta 4, I was unable to see my character creation but that was caused by having CCC set to force AA on - resetting it to application controlled worked fine.  Not sure if that's still an issue, as with beta 4 there wasn't AA ingame, and now there is.

    (edit for adding card type and spelling errors)

  • gatherisgatheris Member UncommonPosts: 1,016

    rather not use a previous version of drivers but really want to give the beta a try this time around

    i don't have any issue creating or choosing my character but once in game the graphics - at least the visible ones are completely crazy

    big red boxes

    strange sparklies

    npcs are ghosts

    and mobs are more or less invisible

    no landscape at all - looks like the game takes place in the clouds

    just very weird

    image

  • VosperVosper Member UncommonPosts: 57

    Just to be sure, do you have the CCC set to force Anti-Aliasing on?  Most of what you describe is what I saw in game, when I had that setting on.  Turning it off made all the difference.

  • bigbudderbigbudder Member Posts: 29

    I had the same trouble with my ATI 5770 not displaying everything. Turn off forced AA, then turn in game to 2X AA and it fixed the problem so i can run the latest driver.

  • Butch808Butch808 Member UncommonPosts: 357

    you guys are lucky up until 11.1 drivers no matter how far i rolled back my drivers i kept getting blue screens of death, sometimes it even hardlocked my computer, but after 11.1 everything was smooth and the fps shot right up so i could play with ultra graphic settings, im on a 4870.

  • gatherisgatheris Member UncommonPosts: 1,016

     

    Originally posted by Vosper

    Just to be sure, do you have the CCC set to force Anti-Aliasing on?  Most of what you describe is what I saw in game, when I had that setting on.  Turning it off made all the difference.

     

    ahh, that's a good possibility

    thanks

    image

Sign In or Register to comment.