Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

re...Vangaurd....

bakon2bakon2 Member UncommonPosts: 125

Is this game still a super resource hog?  I am running  dual 3.0Ghz processors, 4 gigs of ram and a vid card with 1 gig of ram.  Last time I tried this game, it was quite laggy....but I don't think that I had my new vid card  in then...only a 512meg one. 

image

Comments

  • svannsvann Member RarePosts: 2,223

    You'll be fine with that.  Its still got some lag in crafter areas when you first arrive, but no amount of computer will fix that.

  • Gabby-airGabby-air Member UncommonPosts: 3,440

    Even with a beast of a machine you will lagg with settings maxed, the game just isn't optimized well enough.

  • SgtFrogSgtFrog Member Posts: 5,001
    Originally posted by Gabby-air


    Even with a beast of a machine you will lagg with settings maxed, the game just isn't optimized well enough.

     

    My game ran fine when i tried it, and i had similer specs to OP.

    [email protected]

    4GB RAM

    1GB ATI 4890

    image
    March on! - Lets Invade Pekopon

  • quad40quad40 Member Posts: 2

    I know for a fact that the game isn't what people describe it was at launch. I had tried the game about one and a half years back and with my system then I wasn't lagging badly at all. I still have the same computer today which has a 2.5ghz Quad core processor, 4GB of RAM, and a 512MB 8800 GT. That was over a year since it launched so obviously they had already made improvements.  The system was brand new at the time though.  There were a couple areas that I could not run maximum settings at like 40+ fps at and those were the areas that had unfixed memory leaks. By now, I'm sure the majority of those have since been fixed. Anyway, my system is definitely weaker than yours so you should honestly have no issues playing the game.

  • Nekky_FateNekky_Fate Member UncommonPosts: 162

    The game is 100x better than it was at launch but you will still lag. I run an i7 920, 6gb ddr3, Asus rampage extreme II board and an Evga 295 and still lagged out in raids. Also, no it wasn't my connection as I am on 25mbps Fios.

  • csthaocsthao Member UncommonPosts: 1,116

    Been playing recently and I have to tell you, I lagged worse than the last time I played which was maybe 6-8 months ago. But all I did was turn the music and sounds off and all of a sudden the lag was gone. My fps jumped up from 15 to 40-50. It worked for me I guess you can try it out. Besides I prefer listening to my own music anyway.

  • mindw0rkmindw0rk Member UncommonPosts: 1,356

     I have Phenom II X4 945, 4gb ram, 8800GT. 40-60 FPS on Ultra High with 8AA

  • svannsvann Member RarePosts: 2,223

    I dont lag except when crossing chunk lines, entering a crafting area (whether there are crafters or not), and during certain 24 man raids.  This is with max settings on a core2 duo, 4meg, GTX 260.  I hear that adding a SS hard drive eliminates chunkline lag and city lag.  Someone posted recently there was a sale on 30G, which is plenty for vg.

  • fodell54fodell54 Member RarePosts: 859

    I play with a 60G SSD and still have some chunk line lag but as stated I have little to no lag anywhere else in the game, including cities.

    Current System:

    Processor: Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz (8 CPUs), ~2.9GHz

    Memory: 6 GB DDR3 1600 Crucial: Ballstix

    Hard Drive: OCZ Vertex Series Turbo 60 GB SSD/1 TB Seagate Barracuda

    Video Card: ATI Radeon HD 5870

     

Sign In or Register to comment.