Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can't get it working

AmaraoAmarao Member UncommonPosts: 650

I cant seem to log into RF Online.

I downloaded the game client from X-Fire and after signing up, the launcher wont accept my info. I also thought it was strange that I wasnt sent a confirmation email.

I think I may have downloaded the P2P version and am trying to log in with the F2P info, but its still the same game so I'm not sure why it would make a difference. Did the Codemasters version of RF stay P2P while the PH version went free? And if so, how can I connect to the PH server. I had tried to download that before the X-Fire client and the other wouldn't even start.

Thanks ~


  • LagomorphiaLagomorphia Member UncommonPosts: 26

    I'm having the exact same problem! I even requested they resend the confirmation email and I didn't get that one either. It's like I have an account but I can't activate it.

    Anybody have a clue what's going on?

  • IstyreanIstyrean Member Posts: 9

    There's a quick guide how to get RF-Online on Codemaster's forums.

    This is the link:


    Please check there if you did everything to activate your RF-Online account. (and yes, it is free)


  • LagomorphiaLagomorphia Member UncommonPosts: 26

    I finally got it working! I had to have CM customer service manually activate my account. They were very responsive, which was nice.

Sign In or Register to comment.