Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

50 FPS standing still. 15-20 FPS when moving.

MikeJezZMikeJezZ HillerødPosts: 1,197Member Uncommon

 

50 FPS when I am standing still. When I try to move it goes instant down to 10 FPS. When I stop it says 50 FPS again? What the hell?

 

It doesnt matter if I raise or lower my FPS it will stay exact the same.

 

My specs:

 

AMD Phenom II X6 1075T 3.4 GHZ

Nvidia Geforce 660 TI

8 GB DDR3 RAM

Win 7

Playing ATM: Elder Scrolls Online, Diablo 3
MMO's shelted: Check my mmorpg profile
KICKSTARTED: Camelot Unchained. (250 USD)

«134

Comments

  • RigurRigur Johnson City, TNPosts: 53Member
    I was getting a lot of Stuttering. I changed Fullscreen Exclusive to just full screen and it fixed it for me.

    The first MMO you loved will always be the best. You will never get that feeling back stop trying.

  • Nebulizer87Nebulizer87 Waynesville, MOPosts: 29Member
    Yeah im gonna beta test this weekend was looking forward to this game but my computer is getting pretty old figured based on Graphics it would run well on low end systems since it was pretty similar to WoW, but im hearing from a lot of people the game isn't optimized well and a lot of higher end systems aren't even running it well so looks bleak for me :(
  • MikeJezZMikeJezZ HillerødPosts: 1,197Member Uncommon
    Originally posted by Rigur
    I was getting a lot of Stuttering. I changed Fullscreen Exclusive to just full screen and it fixed it for me.

    Tried that without any luck

    Playing ATM: Elder Scrolls Online, Diablo 3
    MMO's shelted: Check my mmorpg profile
    KICKSTARTED: Camelot Unchained. (250 USD)

  • DeniZgDeniZg ZagrebPosts: 668Member Uncommon
    Originally posted by MikeJezZ

     50 FPS when I am standing still. When I try to move it goes instant down to 10 FPS. When I stop it says 50 FPS again? What the hell?

    It doesnt matter if I raise or lower my FPS it will stay exact the same.

     My specs:

     AMD Phenom II X6 1075T 3.4 GHZ

    Nvidia Geforce 660 TI

    8 GB DDR3 RAM

    Win 7

    First of all, Wildstar is still in beta and is not well optimized. However, it's not likely that you will see huge improvement when it goes live.

    Second, buy new CPU. Your old six core AMD simply does not have enough single core performance to fuel MMO's, which are by deafult very CPU/single core intensive.

  • BoldynBoldyn PartillePosts: 265Member
    Originally posted by DeniZg
    Originally posted by MikeJezZ

     50 FPS when I am standing still. When I try to move it goes instant down to 10 FPS. When I stop it says 50 FPS again? What the hell?

    It doesnt matter if I raise or lower my FPS it will stay exact the same.

     My specs:

     AMD Phenom II X6 1075T 3.4 GHZ

    Nvidia Geforce 660 TI

    8 GB DDR3 RAM

    Win 7

    First of all, Wildstar is still in beta and is not well optimized. However, it's not likely that you will see huge improvement when it goes live.

    Second, buy new CPU. Your old six core AMD simply does not have enough single core performance to fuel MMO's, which are by deafult very CPU/single core intensive.

    I got an Intel core2 6600, 2,.4 and 4gb of RAM.

     

    Game runs just fine without looking like LEGO

  • TsumoroTsumoro EozeaPosts: 408Member Uncommon

    I have the same issues here and I just feel the game in Beta isn't optimized yet. This is evident that the Frame rate remains unchanged regardless of settings you affect. 

    Also, Wild Star has a min and a recommended settings on their website, my computer is near double their recommended. So, for me, if I am double their recommended I should be getting 30FPS as a constant although realistically  I should get more. 

    We shall have to see come launch. 

  • MikeJezZMikeJezZ HillerødPosts: 1,197Member Uncommon
    Originally posted by DeniZg
    Originally posted by MikeJezZ

     50 FPS when I am standing still. When I try to move it goes instant down to 10 FPS. When I stop it says 50 FPS again? What the hell?

    It doesnt matter if I raise or lower my FPS it will stay exact the same.

     My specs:

     AMD Phenom II X6 1075T 3.4 GHZ

    Nvidia Geforce 660 TI

    8 GB DDR3 RAM

    Win 7

    First of all, Wildstar is still in beta and is not well optimized. However, it's not likely that you will see huge improvement when it goes live.

    Second, buy new CPU. Your old six core AMD simply does not have enough single core performance to fuel MMO's, which are by deafult very CPU/single core intensive.

    I am aware of that my CPU is not over the top anymore, and I will upgrade in the future. I do however not have enough cash to do it atm.

     

    However, I have played almost all AA MMO's, both older and newer, and the only MMOs I had problems with was: Rift, SWTOR (at release, dont know wabout now didnt even play a full month to resub), TSW, and now Wildstar.

     

    I can run Guild Wars 2, ESO, WoW (I know it's a fossil), and all other MMOs just fine.

     

    I can understand that my CPU should be upgraded, but isn't it missleading that my CPU is very above the recommended settings? I also tried to run the Wildstar test on systemrequirmentslab which shows me that my machine is maxed and ready for Wildstar.

    Playing ATM: Elder Scrolls Online, Diablo 3
    MMO's shelted: Check my mmorpg profile
    KICKSTARTED: Camelot Unchained. (250 USD)

  • TerminalDeityTerminalDeity fairfield, OHPosts: 106Member
    Last beta weekend I was getting 80+ fps, this time it's unplayable. They screwed something up.
  • papariospaparios Indi, INPosts: 48Member

    After last night patch / fix, i m having a big boost in my fps. Its way better than it was before and in other betas. I m prety satisfied and i hope as they said, they are not even half finish the optimizations.

    Hope it gets even better every week. Until now i m having an excellent overall experience with the game.

  • PhryPhry HampshirePosts: 6,297Member Uncommon
    Originally posted by MikeJezZ
    Originally posted by DeniZg
    Originally posted by MikeJezZ

     50 FPS when I am standing still. When I try to move it goes instant down to 10 FPS. When I stop it says 50 FPS again? What the hell?

    It doesnt matter if I raise or lower my FPS it will stay exact the same.

     My specs:

     AMD Phenom II X6 1075T 3.4 GHZ

    Nvidia Geforce 660 TI

    8 GB DDR3 RAM

    Win 7

    First of all, Wildstar is still in beta and is not well optimized. However, it's not likely that you will see huge improvement when it goes live.

    Second, buy new CPU. Your old six core AMD simply does not have enough single core performance to fuel MMO's, which are by deafult very CPU/single core intensive.

    I am aware of that my CPU is not over the top anymore, and I will upgrade in the future. I do however not have enough cash to do it atm.

     

    However, I have played almost all AA MMO's, both older and newer, and the only MMOs I had problems with was: Rift, SWTOR (at release, dont know wabout now didnt even play a full month to resub), TSW, and now Wildstar.

     

    I can run Guild Wars 2, ESO, WoW (I know it's a fossil), and all other MMOs just fine.

     

    I can understand that my CPU should be upgraded, but isn't it missleading that my CPU is very above the recommended settings? I also tried to run the Wildstar test on systemrequirmentslab which shows me that my machine is maxed and ready for Wildstar.

    There is nothing wrong with your PC, chances are its just something their working on, and it will improve. honestly, if your computer isn't good enough, then hardly anyone will buy the game, because yours is probably better than at least 80% of the PC's out there today. Rather than Upgrade your cpu anyway, i'd maybe opt to upgrade the GPU, although its more than good enough as is. image

  • chronoss2015chronoss2015 peterborough, ONPosts: 155Member Uncommon

    its damn unplayable period

     

    dont care what the excuse is there is your beta ....its over and done with

     

    anyone having a fast time is bullshitting us and they cant handle theload.

     

    i have a triple core 3.3 ghz with 16 gb ram and a gt 640 

     

    http://www.geforce.com/hardware/desktop-gpus/geforce-gt-640-oem/specifications

     

    do not tell me i need to upgrade...ROFL

    i should not have to for such shitty looking graphics.

  • MikeJezZMikeJezZ HillerødPosts: 1,197Member Uncommon
    Glad to see that I am not the only one with these problem.

    Playing ATM: Elder Scrolls Online, Diablo 3
    MMO's shelted: Check my mmorpg profile
    KICKSTARTED: Camelot Unchained. (250 USD)

  • mistafistmistafist Warren, OHPosts: 119Member Uncommon
    Originally posted by chronoss2015

    its damn unplayable period

     

    dont care what the excuse is there is your beta ....its over and done with

     

    anyone having a fast time is bullshitting us and they cant handle theload.

     

    i have a triple core 3.3 ghz with 16 gb ram and a gt 640 

     

    http://www.geforce.com/hardware/desktop-gpus/geforce-gt-640-oem/specifications

     

    do not tell me i need to upgrade...ROFL

    i should not have to for such shitty looking graphics.

    A gt 640 is slower than a 460 GTX, which was released 4 years ago.  You need to upgrade.

    Still, with a 780 Classified, performance was *generally* acceptable.  However, some areas dropped fps to 30 or so and needed optimization.

  • notmexnotmex Omaha, NEPosts: 43Member
    Originally posted by Nebulizer87
    Yeah im gonna beta test this weekend was looking forward to this game but my computer is getting pretty old figured based on Graphics it would run well on low end systems since it was pretty similar to WoW, but im hearing from a lot of people the game isn't optimized well and a lot of higher end systems aren't even running it well so looks bleak for me :(

    Yea, seems sloppy lazy programming is the name of the game these days.

     

    It is no where near blizzard games in terms of performance.

  • IceAgeIceAge SomeWhere In ..Posts: 1,013Member Common

    Well, today was the first day to login during this Beta Weekend, and I must say that I see a very high improvement in crowed areas, where'as in the last Beta Weekend, I had massive FPS drop when entered in said areas, same as op .

    So I don't know what they did this weekend, but they did a good job optimizing the client. 

    I am pretty sure that when Wildstar will launch, a lot of people will stop having FPS drops, because I have high faith in Carbine :)

     

    Reporter: What's behind Blizzard success, and how do you make your gamers happy?
    Blizzard Boss: Making gamers happy is not my concern, making money.. yes!

  • SiphaedSiphaed Everywhere!Posts: 879Member Uncommon
    Not sure what's going on with the OP's performance, but mine was great yesterday.  I only had a slight hitch of low FPS during a Walatiki Temple match, but this was at the time I was watching a Twitch Stream, playing the game client, running Pandora, and still had my 9 normal FF tabs up.  Oh,....and for some reason I still had Origin running in the background.  Technically was my bad. After I remedied the situation, no issues otherwise.


  • JeroKaneJeroKane OsloPosts: 5,353Member Uncommon
    Originally posted by Siphaed
    Not sure what's going on with the OP's performance, but mine was great yesterday.  I only had a slight hitch of low FPS during a Walatiki Temple match, but this was at the time I was watching a Twitch Stream, playing the game client, running Pandora, and still had my 9 normal FF tabs up.  Oh,....and for some reason I still had Origin running in the background.  Technically was my bad. After I remedied the situation, no issues otherwise.

    I don't often say this. But this game has absolutely terrible performance! Especially for it's cartoony.... ehh stylish Graphics. Period!

    I can run pretty much all MMO's to date without problems, including TSW and ESO at high settings with very acceptable performance!

    But Wildstar is a first since a long time I just cannot get to perform adequate no matter what. (Tabula Rasa was last game that had similar issues with choppy performance that was almost impossible to fix on my side).

    I play games long enough, build plenty systems myself over the years and know how to tune stuff.

    But Wildstar is a tough nut to crack at the moment. With such cartoon graphics it shouldn't run this crappy!

    It suppose to be one of the so called excuses for going for cartoon graphics. To make it run on most systems.

    Well.... so far they are failing at that. Sorry.

  • TsuruTsuru Silverspring, MDPosts: 264Member Uncommon
    The best thing to do for now is force the game to run in 32 bit. Right click the shortcut you use, and change the compatibility to Windows XP (Service Pack 3). The game will now be running as a 32 bit client and will fix studdering and fps issues with the 64 bit client.
  • TsuruTsuru Silverspring, MDPosts: 264Member Uncommon
    Originally posted by JeroKane
    Originally posted by Siphaed
    Not sure what's going on with the OP's performance, but mine was great yesterday.  I only had a slight hitch of low FPS during a Walatiki Temple match, but this was at the time I was watching a Twitch Stream, playing the game client, running Pandora, and still had my 9 normal FF tabs up.  Oh,....and for some reason I still had Origin running in the background.  Technically was my bad. After I remedied the situation, no issues otherwise.

    I don't often say this. But this game has absolutely terrible performance! Especially for it's cartoony.... ehh stylish Graphics. Period!

    I can run pretty much all MMO's to date without problems, including TSW and ESO at high settings with very acceptable performance!

    But Wildstar is a first since a long time I just cannot get to perform adequate no matter what. (Tabula Rasa was last game that had similar issues with choppy performance that was almost impossible to fix on my side).

    I play games long enough, build plenty systems myself over the years and know how to tune stuff.

    But Wildstar is a tough nut to crack at the moment. With such cartoon graphics it shouldn't run this crappy!

    It suppose to be one of the so called excuses for going for cartoon graphics. To make it run on most systems.

    Well.... so far they are failing at that. Sorry.

    This is an issue gaming companies run into when developing their own Game Engine. While yes, they have the freedom to do what they want with it, the downside is they will run into optimization  issues. But again, since its their own engine they can easily fix said issues. I've played through multiple beta weekends over the year and i can easily say it has improved GREATLY. With another month left, they can easily fix the remaining issues.

  • TheHavokTheHavok San Jose, CAPosts: 2,399Member Uncommon

    I'm playing on a cheap gaming laptop at the moment and its running like shit.  BUT, that's kind of to be expected, atleast for me, since

    A)The game isn't fully optimized yet

    2)My rig is crappy.

  • papariospaparios Indi, INPosts: 48Member
    Originally posted by Tsuru
    Originally posted by JeroKane
    Originally posted by Siphaed
    Not sure what's going on with the OP's performance, but mine was great yesterday.  I only had a slight hitch of low FPS during a Walatiki Temple match, but this was at the time I was watching a Twitch Stream, playing the game client, running Pandora, and still had my 9 normal FF tabs up.  Oh,....and for some reason I still had Origin running in the background.  Technically was my bad. After I remedied the situation, no issues otherwise.

    I don't often say this. But this game has absolutely terrible performance! Especially for it's cartoony.... ehh stylish Graphics. Period!

    I can run pretty much all MMO's to date without problems, including TSW and ESO at high settings with very acceptable performance!

    But Wildstar is a first since a long time I just cannot get to perform adequate no matter what. (Tabula Rasa was last game that had similar issues with choppy performance that was almost impossible to fix on my side).

    I play games long enough, build plenty systems myself over the years and know how to tune stuff.

    But Wildstar is a tough nut to crack at the moment. With such cartoon graphics it shouldn't run this crappy!

    It suppose to be one of the so called excuses for going for cartoon graphics. To make it run on most systems.

    Well.... so far they are failing at that. Sorry.

    This is an issue gaming companies run into when developing their own Game Engine. While yes, they have the freedom to do what they want with it, the downside is they will run into optimization  issues. But again, since its their own engine they can easily fix said issues. I've played through multiple beta weekends over the year and i can easily say it has improved GREATLY. With another month left, they can easily fix the remaining issues.

    True and as they said a few days ago, they are not even half finish the optimization for launch.

  • coleman11bcoleman11b New Orleans, LAPosts: 12Member Common
    It's simply another poorly optimized game being released. Developers supposedly aimed for a Vanilla wow experience. The glaring exception, their game doesn't run well. That can be a death sentence in the MMO world. Poor thinking on Wildstar Dev's part.
  • ButeoRegalisButeoRegalis Tijeras, NMPosts: 506Member Uncommon

    I really need to stop looking at these "game runs like sh!t!!1!!1! wildstra suxzors!!" threads...

    If you don't know what "in beta" means please don't play games that are labeled as still in beta.

    image

  • VicDynamoVicDynamo Michigan, MIPosts: 234Member
    The devs acknowledge that the game still needs optimization and theu are making improvements with each patch.
  • papariospaparios Indi, INPosts: 48Member
    Originally posted by Prhyme
    The devs acknowledge that the game still needs optimization and theu are making improvements with each patch.

     

    Yep, thats why they are saying client optimization isnt even half finished yet. There is 1.5 month ahead until launch, wait and we will see what happens :)

«134
Sign In or Register to comment.