Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

Info so far on debug mode myth and load lag

Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member

if anyone else experiences anything else or new post it so it can be consolidated; so far with a few people in game.

 

1) According to a few players in VAMP it's worse at the moment.

 

2) Per Umberto: "Still multiple processes running as well."

 

3) "there are still load laggs. I remember them saying darkfall arena, 2010, 2.0, unholy wars would get rid of player load lagg and that it was a key point in deciding to create a new game but im still getting this little hiccup when someone enters my area making me aware of a player being around."

 

4) I can confirm, my performance isn't any different from beta. Debug mode ftw.

 

5) Melkrow:

Verdict: BUSTED
There was no debug mode.
Same resolution, same settings (absolute minimum), standing in the same place, looking at the same thing.
In Beta: 90-95 FPS
At Launch: 88-93 FPS

 

6) Raapnaap from these very forums --> I can confirm having the same performance loss, load lag, and input delay as during most of beta.

 

7) CorDox: Performance is pretty much identical to beta for me, still get hitching, load lag when players enter the area, freezes when sorting inventory at bank. All of which were blamed on debug mode. Memory usage is identical. Still barely uses multiple cores, etc.

I'm wondering what exactly was in that "patch" that warranted a redownload?
«1

Comments

  • HancakesHancakes flint, MIPosts: 1,045Member

    Tasos will produce another line of BS as to why the "debug mode" is still "on". 

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member
    Load lag confirmed still in also from various users while a lot of people are not even in game yet.
  • HancakesHancakes flint, MIPosts: 1,045Member
    Originally posted by Deerhunter71
    Load lag confirmed still in also from various users while a lot of people are not even in game yet.

    Load lag is an inherent problem with engine, yet Tasos used the debug client as an excuse.

  • funconfuncon Key West, FLPosts: 258Member
    I knew the beta version would run the same as the launch version. The game just isn't smooth enough.
  • HancakesHancakes flint, MIPosts: 1,045Member
    Originally posted by funcon
    I knew the beta version would run the same as the launch version. The game just isn't smooth enough.

    I think most did, despite AVs lies to the contrary.  I'm guessing the launch version will be worse given the increased server load vs the rather empty beta.

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member

    Damn - harvesting bugs also, lol  People might be making dragon armor by end of day if the same with iron nodes...

     

    My bad it keeps failing every time for osme people :)

  • PieRadPieRad Odense MPosts: 1,108Member
    Originally posted by Deerhunter71

    Damn - harvesting bugs also, lol  People might be making dragon armor by end of day if the same with iron nodes...

     

    "some ppl get 17 timber per hit,"

    lol

    image

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member
    Originally posted by PieRad
    Originally posted by Deerhunter71

    Damn - harvesting bugs also, lol  People might be making dragon armor by end of day if the same with iron nodes...

     

    "some ppl get 17 timber per hit,"

    lol

    If you are playing mys well knock out the harvesting feats real quick for damn sure before they fix it!

  • RealbigdealRealbigdeal Vimont, QCPosts: 1,625Member
    They never said they removed the debug mode. If you play, press alt + del. Check if there's more than 1 darkfall processing at once.

    C:\Users\FF\Desktop\spin move.gif

  • GadzyGadzy TønderPosts: 143Member
    Originally posted by Deerhunter71

    Damn - harvesting bugs also, lol  People might be making dragon armor by end of day if the same with iron nodes...

     

    "some ppl get 17 timber per hit,"

    17 bonus timber is a reward for an early harvesting feat. Nobody gets it "per hit".

    This is what happens when a lot of people on the rag transmit a lot of information.

  • RandomDownRandomDown Louisville, KYPosts: 145Member
    Originally posted by Realbigdeal
    They never said they removed the debug mode. If you play, press alt + del. Check if there's more than 1 darkfall processing at once.

    They said they were going to "turn it off" when the game was released. And as of today it is supposed to be released so yes, it should be removed.

  • BrownAleBrownAle fantasyland, MEPosts: 399Member

    From what i heard, and this was early in on the betas, was that the multiple processes was their way of getting multi core use out of the game.

    Now, the argument with this is...what the hell was debug mode and did it really even exist if this is the case. 

    I have a feeling that the multiple processes was in fact their attempts to multi-core the game, not saying a few of those processes were not the debug logger though.

    The game played smooth for me even int he midst of the worst of beta times, simply because my rig is no joke.

     

    It would be interesting to see if people with duo core systems have less processes than someone with a quad core (or more).

     

    I really suspected that the debug argument was more of a means to hide a poorly optimized multicore structure.  Im sure there was a logger involved though but i doubt it has that large of an effect on gameplay as people saw during beta.

     

    I dunno, go play a week of MO or Xyson (if that game is even still alive) then go back to DF and it will feel like optimization perfection lol

     

    Oh, and did it really launch?  I think im going to skip launch tbh

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member
    Originally posted by RandomDown
    Originally posted by Realbigdeal
    They never said they removed the debug mode. If you play, press alt + del. Check if there's more than 1 darkfall processing at once.

    They said they were going to "turn it off" when the game was released. And as of today it is supposed to be released so yes, it should be removed.

    That - BUT most concerning is the load lag still in the game.  That is a killer for a game based on PvP when it is basically built in radar for the game.

  • HancakesHancakes flint, MIPosts: 1,045Member
    Originally posted by BrownAle

     

    The game played smooth for me even int he midst of the worst of beta times, simply because my rig is no joke.

     

     

    Sure...image

    Everyone experiences load lag in DFUW, it's an inherent fault with the game itself.  RAMdisks, SSD, CPU, RAM or killer connection doesn't make any difference as it isn't client hardware related.

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member

    Now reports of constant crashes by numerous players/clanmates....

     

    1) when changing options in the game

    2) also "its seems to be if you use any bind without a use atm (empty raidialslot, quickslot) you crash"

     

    3) Cattboy - Sin:

    Cannot load into the game--

    Crashes 24/7

    Submitted many reports
  • luvbooxluvboox Smalltown, IDPosts: 87Member
    Originally posted by Hancakes
    Originally posted by BrownAle

     

    The game played smooth for me even int he midst of the worst of beta times, simply because my rig is no joke.

     

     

    Sure...image

    Everyone experiences load lag in DFUW, it's an inherent fault with the game itself.  RAMdisks, SSD, CPU, RAM or killer connection doesn't make any difference as it isn't client hardware related.

    The only noticable lag I experienced during the beta was when the music started up. That's it. I also have a pretty doomful gaming machine.

  • HancakesHancakes flint, MIPosts: 1,045Member
    Originally posted by luvboox
    Originally posted by Hancakes
    Originally posted by BrownAle

     

    The game played smooth for me even int he midst of the worst of beta times, simply because my rig is no joke.

     

     

    Sure...image

    Everyone experiences load lag in DFUW, it's an inherent fault with the game itself.  RAMdisks, SSD, CPU, RAM or killer connection doesn't make any difference as it isn't client hardware related.

    The only noticable lag I experienced during the beta was when the music started up. That's it. I also have a pretty doomful gaming machine.

    Riiight!   So why is AV claiming to fix an issue or saying XXX is causing an issue that doesn' t exist? image

    Is AV secretly shipping some super fanboy only client?

     

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member
    Originally posted by Hancakes
    Originally posted by luvboox
    Originally posted by Hancakes
    Originally posted by BrownAle

     

    The game played smooth for me even int he midst of the worst of beta times, simply because my rig is no joke.

     

     

    Sure...image

    Everyone experiences load lag in DFUW, it's an inherent fault with the game itself.  RAMdisks, SSD, CPU, RAM or killer connection doesn't make any difference as it isn't client hardware related.

    The only noticable lag I experienced during the beta was when the music started up. That's it. I also have a pretty doomful gaming machine.

    Riiight!   So why is AV claiming to fix an issue or saying XXX is causing an issue that doesn' t exist? image

    Is AV secretly shipping some super fanboy only client?

     

    Get this one:

    "Still as bad performance as at beta. I've crashed twice so far. If you press a hotkey for empty item slot, you crash. Now I got killed and felt through the world and crashed.

    Welcome to paid beta."
  • kadepsysonkadepsyson sun prairie, WIPosts: 1,937Member

    Guys don't worry, the game was ready half a year go, it was just put into a five month beta because of Valve.  It's running perfectly right now and has all features promised for the launch months ago.

     

    Seriously though, did anyone really expect different?

    El Psy Congroo

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member
    Originally posted by kadepsyson

    Guys don't worry, the game was ready half a year go, it was just put into a five month beta because of Valve.  It's running perfectly right now and has all features promised for the launch months ago.

     

    Seriously though, did anyone really expect different?

    I hear ya and I did not expect any different either.  Just sad to promote a game focused on PvP and yet load lag is the one thing that CANNOT be in the game as that just defeats that goal, especially full loot....

     

    Person A  to Person B = felt load lag let's roll and bank our shit we got too much to lose like a few keys and all this other stuff....

  • luvbooxluvboox Smalltown, IDPosts: 87Member
    Originally posted by Hancakes
    Originally posted by luvboox
    Originally posted by Hancakes
    Originally posted by BrownAle

     

    The game played smooth for me even int he midst of the worst of beta times, simply because my rig is no joke.

     

     

    Sure...image

    Everyone experiences load lag in DFUW, it's an inherent fault with the game itself.  RAMdisks, SSD, CPU, RAM or killer connection doesn't make any difference as it isn't client hardware related.

    The only noticable lag I experienced during the beta was when the music started up. That's it. I also have a pretty doomful gaming machine.

    Riiight!   So why is AV claiming to fix an issue or saying XXX is causing an issue that doesn' t exist? image

    Is AV secretly shipping some super fanboy only client?

     

    I have no idea why people are experiencing lag. I do not have the answers for all that. But I suppose I should doubt my own experience because you tell me that I can't have experienced what I did. Surely that is the only logical path, because, unlike me, you are omniscient.

  • Deerhunter71Deerhunter71 Richmond, VAPosts: 527Member

    Melkrow on debug mode:

    Verdict: BUSTED

    There was no debug mode.

    Same resolution, same settings (absolute minimum), standing in the same place, looking at the same thing.

    In Beta: 90-95 FPS
    At Launch: 88-93 FPS

    ---------------------------------------------------------------------------------------------------------------------------------------------------------

    Our very own raapnaap - I can confirm having the same performance loss, load lag, and input delay as during most of beta.

    ---------------------------------------------------------------------------------------------------------------------------------------------------------

     

    Evoke = The problem is that the game has much worse performance than DF 1. How much this will impact sieges I don't think anyone knows. But they've actually gone BACKWARDS in performance without actually making the game look better. Amazing.

  • BadaboomBadaboom Moose Jaw, SKPosts: 2,380Member
    Originally posted by Deerhunter71

    Melkrow on debug mode:

    Verdict: BUSTED

    There was no debug mode.

    Same resolution, same settings (absolute minimum), standing in the same place, looking at the same thing.

    In Beta: 90-95 FPS
    At Launch: 88-93 FPS

    ---------------------------------------------------------------------------------------------------------------------------------------------------------

    Our very own raapnaap - I can confirm having the same performance loss, load lag, and input delay as during most of beta.

    ---------------------------------------------------------------------------------------------------------------------------------------------------------

     

    Evoke = The problem is that the game has much worse performance than DF 1. How much this will impact sieges I don't think anyone knows. But they've actually gone BACKWARDS in performance without actually making the game look better. Amazing.

    UW looks alot better than DF1...unfortuneately it looks to be at the expense of performance.

    Edit:  Hope to try it out in an hour.

  • luvbooxluvboox Smalltown, IDPosts: 87Member
    As I said above, I haven't had much lag (aside from the music loading), but if there is a lot for some people, that is a big problem. Hopefully AV will do some optimizations to reduce any lag.
  • PAL-18PAL-18 AnachronoxPosts: 802Member

    Keep those reports coming lads,im following this like old Championship Manager match.

    Who will be the worlds first hacker and gets his name on the famous wall, worlds first guys ,amazing title!

    So, did ESO have a successful launch? Yes, yes it did.
    By Ryan Getchell on April 02, 2014.
    **On the radar:http://cyberpunk.net/**

«1
Sign In or Register to comment.