Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

Game is buggy and has latency problems

Astro6Astro6 Posts: 204Member Uncommon

I have been playing over a week in cb2 while the game is fun being a beta it's still buggy offline jobs often don't work, training skills often don't activate when you go offline with vip and there is a latency problem of ping spikes that sometimes makes the game unplayable.

I understand this is called a beta but according to forums and dev post there will be no wipe but you have to either find a beta key or pay vip.

I find it odd though i have not seen a patch in over a week and they limit free play i'm hoping they fix those lag spikes and fix problems soon talking to guild and other players they are all having same problems.

 

Comments

  • BiskopBiskop AvalonPosts: 709Member

    Latency issues and lag, yes. Hopefully that will be fixed.

    As for the other issues, I've never experienced them. Offline jobs only works when there are available jobs in the area. Perhaps you logged out in Chengdu or some other heavily populated place where all jobs were taken? You can see whether there are any free jobs as you log out.

    Offline cultivation only continues until you reach the next level, after that it's inactivated and you have to log in to keep cultivation going (or change skill). So it's not like in EVE where you just queue skills and go offline for a month.

    I have to say AoW is relatively bug free. There are some annoying bugs but nothing gamebreaking imo.

     

  • BatzenbaerBatzenbaer BerlinPosts: 25Member

    U can log off in a Area with Jobs are avaible,but u got nothing after 12h or more offline.

    This is without being kidnapped.That must be a Bug or Snail want us exchange Gold into Silver.^^

    image

  • bcbullybcbully Westland, MIPosts: 8,277Member Uncommon
    Originally posted by Batzenbaer

    U can log off in a Area with Jobs are avaible,but u got nothing after 12h or more offline.

    This is without being kidnapped.That must be a Bug or Snail want us exchange Gold into Silver.^^

    I've had it happen to me before. It was a bummer.

     

    edit- I did have 2 lag spikes lastnight too. I run about 109 on the norm . I live in michigan.

     

     

  • TsaboHavocTsaboHavoc PinheiralPosts: 351Member
    buggy? no... but the latency issues are keeping me from having fun.
  • fldashfldash Oklahoma City, OKPosts: 227Member

    I have 20mb connection in central US and never have any noticable lag in other games. Last night I ran TV for the first time and it was impossible to keep combos up on any of the bosses due to skills not firing because of lag. I once got in a good groove to 50-some combo count but then a skill pressed didn't fire and all was lost.

    There is something about the combat driving me crazy and I think that is it...

    Former xFire user... I only wanted a game tracker and messenger, not a screenshot taker, video recording, broadcasting piece of bloatware.

  • bcbullybcbully Westland, MIPosts: 8,277Member Uncommon
    Originally posted by fldash

    I have 20mb connection in central US and never have any noticable lag in other games. Last night I ran TV for the first time and it was impossible to keep combos up on any of the bosses due to skills not firing because of lag. I once got in a good groove to 50-some combo count but then a skill pressed didn't fire and all was lost.

    There is something about the combat driving me crazy and I think that is it...

    Lastnight was strange. The two spikes I had were 5 and 1 sec respectively. That hasb't happened before. Load maybe? Idk. I have no problems today.

Sign In or Register to comment.