Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

TERAble Support

Frenchie1234Frenchie1234 RotterdamPosts: 5Member

I have a dual boot Win7 on my iMac and I did activate my login email, but I can't authorize my account (failed authorization message). I've disabled addons, virusscanner, the lot on IE without effect. When I want to enter a support ticket I also must authorize and that is the @#$% problem I want to address (can't update account message)! I am using a smartfren modem stick as the connection in my place is slow.

Why need to authorize in the first place? You already have my unique email address and password. And I'm not going to sell or lent out my f2p account I can't access. Isn't a simple IP check sufficient?

Anyone else with this problem? I want to know if it's local, iMac or modem stick related. Is ther another way to contact enMasse to reach support?


  • muffins89muffins89 Yakima, WAPosts: 1,459Member Uncommon
  • Frenchie1234Frenchie1234 RotterdamPosts: 5Member
    That is the support site where I tried to summit a ticket without success...
  • MdpatsMdpats Peekskill, NYPosts: 176Member
    Originally posted by Frenchie1234
    That is the support site where I tried to summit a ticket without success...

    What do you mean "without success?"  How long has it been since you've submitted a request?  Did they respond back?

  • muffins89muffins89 Yakima, WAPosts: 1,459Member Uncommon
    click on "Live Chat" at the bottom of the page.
  • XirikXirik Yorkton, SKPosts: 1,699Member
    also if your waiting for your Tera "armor code"  Email then it might just be that they are clogged. It took 5 hours for my friend to finally get it.

    "You have some serious mental issues you may need to seek some help for. There are others who post things, but do not post them in the way you do. Out of every person who posts crazy shit in this forum, you have some of the craziest and scariest" -FarReach

  • Frenchie1234Frenchie1234 RotterdamPosts: 5Member

    Each attempt to contact them I get an unknown device message and after entering the mailed authorization code I enter it fails to authorize me. So, no launcher login, no support ticket and no live chat possible! The mailed "armor code" is not the problem but after entering it I get the failure message.

    I have trying to contact them several times in the above ways since the 6th of february...

Sign In or Register to comment.