Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

Soo.. how many of you with 60fps?

12346

Comments

  • gracefieldgracefield BallymenaPosts: 275Member Uncommon

    Something else arises out of all this - aren't ANet being a little disingenuous with the minimum specs as stated on the box?

    I haven't played yet - and judging by half of what's been said on here, may never be able to play it on my dinosaur rig - but it seems to me that's there's little chance of anybody who just has 'minimum specs' being able to play this at anything like a decent level.

    I know these are stated as 'minimum specs' but that can still be misleading for people with little experience of gaming. I do think that could be made a little clearer at the point of purchase.

  • SysFailSysFail LondonPosts: 375Member
    The games running nicely with everything maxed  with i5 2.5k cpu and dual 6850's in crossfire. Crossfire gives 20-30 more fps from what ive experienced, so not a huge boost but still a boost, but that should improve with future profiles.
  • Loke666Loke666 MalmöPosts: 17,969Member Uncommon
    Originally posted by MosesZD

    That's because they're simpler.   I know you THINK they're more complex, but in reality the developer has much better control over the environment and deliberately limits every situation to keep total poly-count down while tricking your eyes into believing things are more complex than they are.

    You can't do that in an MMO because, unlike your heavily controlled single-player game, players can go everywhere and do everything...  So to make a 'good looking' MMO, you crush the people with bottom-feeder computers who, because they can play Crysis at 40FPS think it'll work.    Only it's not true much to their unhappiness.  So, the best rule of thumb I know is:   Single player games bottle-necked with GPU speed.   MMOs are also bottled-necked with VRAM.  (Rule of thumb, so don't whine about it.  It's a rule of thumb, not an iron-hard lawf.)

    Which gets us to your FPS...    There's more to the spec-story than you're telling us.    An "HD4800 series" card can be a cheap-bottom-dwelling card or a robust, but obsolete (DX) card.   I'm suspecting it's a shared memory or low-memory card integrated card, but I have no proof.

    Now, I have an HD5850 with 2GB VRAM.  It's over-clocked and has the GPU capacity close to a 7850.   And, ironically, here is me in close to the same spot from three days ago:   http://www.flickr.com/photos/86072414@N06/7884024340/    116 FPS. 

    Here is my settings which I did earlier in Divinity's Reach:   http://www.flickr.com/photos/86072414@N06/7887186050/    60FPS with a lot of people around, crafting, some particle effects, a long, complex draw and all the specs as high as possible.

    Here I am in a world-boss event (Vile Maw) in the Norn starter zone.   Very long draw distances, muliple tornados (at least 6) about 50 players...    Huge number of spells, particle effects out the wazoo:  42FPS & somewhat later at 44FPS.

    http://www.flickr.com/photos/86072414@N06/7883880110/

    http://www.flickr.com/photos/86072414@N06/7883868818/

    And a dynamic event (about 25 people and 20 centaurs rushing us):   http://www.flickr.com/photos/86072414@N06/7884020938/    60FPS

    Normal soloing:

    http://www.flickr.com/photos/86072414@N06/7883979276/   80FPS

    http://www.flickr.com/photos/86072414@N06/7883973440/  77FPS

    It's your computer, mate.   It isn't the game.   Most GOOD LOOKING MMOs I have played would have died in the Vile Maw fight.   SWTOR would have been going like a slide show and tearing.    DCUO would have stuttered to death.   STO...  Who knows, I probably would gone back it time...     Rift would stuttered.    LOTRO would stutter. 

    So, when I'm in a huge boss fight, moving around, shooting, with 50 other people...

    Great post.

    It is also one of the reasons that FPS games generally have more "modern" graphics than MMOs (that and the fact that MMOs takes about 5 years to make).

    And yes, maxing out a new MMO takes a good computer. On the plus side can my crappy laptop run it fine with its Nvidia 330M GFX card on medium settings. So I still think OP also have some crap clogging up his system. And yeah, the laptop do have a Intel quad processor so it aint a complete waste of space but still...

  • IPolygonIPolygon ViennaPosts: 707Member Uncommon
    I get 60 fps at ~65% gpu usage. Sometimes I am experiencing graphical artifacts or glitches, but they happen after hours of gameplay and are not that bad. I hope for the next driver update to solve this issue, the last one was already great.
  • SkuzSkuz WorcesterPosts: 1,034Member Uncommon

    Well I have to say that I am pretty seriously unhappy with the optimisation.

    I have a solid pc set up, I7 2700k, 16GB DDR II RAM, 120GB SSD/3TB HDD, and a HD6870 2GB (with a slave HD6870 helping with co-processing).

    I am struggling to get more than 19FPS which I see as piss-poor on my rig, I get a solid 80FPS in SWTOR and it's usually 100+, constant 60FPS in WoW, consistently 60 + FPS in TSW - all at max settings.

    Changed driver versions a few times with little to no noticeable improvement.

  • TalketzantoTalketzanto Posts: 203Member Uncommon

    Brand new computer bought this past week.

    i5-3570

    3.4

    16gb ram

    amd 7850  2gb

     

    things empty, updated drivers. perfect internet connection.

    I get 70-125 fps in guild wars 2 yet i see people rubber banding when they walk....almost like my game isn't catching up to the server or vice versa......

     

    PS: game ran fine up until just recently.

  • SelfDestructProSelfDestructPro Oxnard, CAPosts: 323Member Uncommon

    I don't have the greatest of setups either.  OP it's probably your ram.  I'm not familiar with that graphics card so it could be that too, but my biggest issue whenever I start setting my graphics higher is the total amount of memory that I'm using at any one time.  You can sort this out by checking out your system resource usage.

    I run the game in 1920x1080 on a 42" HD TV.  I also have an Nvidia 480 GTX.  I've got 5GB Ram (not the fastest either) a Quad Core 2.2Ghz.  CPU takes almost no hit while the game is running.  RAM runs at almost a constant 75-80%.  When I first started the game it had me at a happy medium graphics settings which looked ok and also got me 60FPS.  Now I run at maxium graphics and I get 23-30FPS.  Which honestly is perfect for me.  While 60FPS is what everyone loves to shoot for, it can also sometimes be fake looking.  Around 30FPS looks very lifelike to me.  And it won't mean that everyone and everything in the game will be skipping and jumping.  This is a major misconception.  The only thing you might notice, but probably won't is some blending in the combat animations.  While I could go on and on about my experience with lower FPS, and how I think it's better anyway, I'll just give you a link to an article I read a while back.

    http://amo.net/NT/02-21-01FPS.html

  • IPolygonIPolygon ViennaPosts: 707Member Uncommon
    Originally posted by Skuz

    Well I have to say that I am pretty seriously unhappy with the optimisation.

    I have a solid pc set up, I7 2700k, 16GB DDR II RAM, 120GB SSD/3TB HDD, and a HD6870 2GB (with a slave HD6870 helping with co-processing).

    I am struggling to get more than 19FPS which I see as piss-poor on my rig, I get a solid 80FPS in SWTOR and it's usually 100+, constant 60FPS in WoW, consistently 60 + FPS in TSW - all at max settings.

    Changed driver versions a few times with little to no noticeable improvement.

    You might want to uncheck some of the settings and see which one is the culprit.

  • TeknoBugTeknoBug Calgary, ABPosts: 2,156Member

    Most modern MMO games release these days need a decent PC, Blizzard released WoW with low system specs so they can draw a larger playerbase, people with PC's from 1998 were able to play WoW. Games like Vanguard, Age of Conan and so forth needed a modern PC (I remember AoC ran like shit even on the newest PC build).

    image
    image

  • TalRashaTalRasha GroningenPosts: 827Member
    Originally posted by MosesZD
    Originally posted by Masa1

            Card name: ATI Radeon HD 4800 Series

     

     

    Which gets us to your FPS...    There's more to the spec-story than you're telling us.    An "HD4800 series" card can be a cheap-bottom-dwelling card or a robust, but obsolete (DX) card.   I'm suspecting it's a shared memory or low-memory card integrated card, but I have no proof.

     

    There is no HD 4800 card that is integrated or uses shared memory.

    The lowest possible variant is the HD 4830 with 512 MB dedicated GDDR3. It's outdated in that it only supports up to DX 10.1. 57.6 GB/s bandwidth (integrated cards are at less than 12.8 GB/s).

    He should be able to use higher settings with that card than what he posted in the schreenshot. Like you said, there must be something else to the spec-story that prevents him from doing that, or he put everything on low on purpose, and setting half the settings on high would give the same fps result. Since not all of the settings have any noticable effect on fps.

  • TalketzantoTalketzanto Posts: 203Member Uncommon

    Theres tons of high end systems having this problem. Also theres tons of people who have low end machines have no problem.......It has to do with there server...

     

    I have this problem with a high end machine and right around 1am eastern the lag and rubber banding disappears.......

     

    My question is, can they fix this? or is it one of those things where some will suffer so the majority can play lag free...

     

    again i had no lag at all till 3 days ago

  • Masa1Masa1 LapuaPosts: 318Member Uncommon

    A lot of you were complaining about me not telling the exact GPU name. Well here it is: ATI/AMD Radeon HD 4850 (RV770 PRO)

  • JZeroVNJZeroVN Packwood, WAPosts: 46Member

    FPS varies quite a bit for me.  I've seen it from 30's to 70's.  I play mostly on the defaults it picked for me but I turned down a few flashy items.  Other than occasional blips which have so far passed quickly the graphics perform well for me.

     

    Intel I-7 chip, quad-core, 3GHz., Windows 7, 12GB RAM,  

    GeForce GTX 260, driver 8.17.12.5936

    1680x1050 resolution

  • ThraliaThralia EngerPosts: 219Member

    gw2 is a HORRIBLE optimized game. we all saw it in the beta and we continue to see it now. game still cpu bou

  • evolver1972evolver1972 Port Orchard, WAPosts: 1,118Member
    Originally posted by Masa1
    Originally posted by FuryV

    For crying out loud, stop living in the past.  You already admitted it, your PC sucks.  Don't blame the game.  I've got the game on full graphics with a steady 60 FPS, using a mid range system.  You ripped yourself off by not upgrading your PC, it's not ANET's fault in the slightest.

     

    It's your's.

    I could upgrade... but every other modern game works with max FPS. It's ONLY GW2 which works so badly. Why spend 1500€ for 1 game? It's GW2s fault.

    It's their fault they made a game your PC can't handle?  Stop whining and dish out the cash for a decent video card and you should be fine.

    BTW, you don't need to spend that much even for a new system that will play the game with decent settings.  I was just checking ebay last night about a new laptop for my wife because hers won't play the game at all (stupid ATI HD Mobility 5470 card - and laptops don't upgrade well) and I found a slightly used one for $360 that would play GW2 with mid range specs.  So, considering that, and the fact that PCs are upgradeable piece by piece, you don't need to spend that much on it.

     

    Also, maybe try setting your resolution a little lower?  And, DDR2 RAM?  People still use that?  I didn't realize they made Quad core MBs that used those.

     

    image

    You want me to pay to play a game I already paid for???

    Be afraid.....The dragons are HERE!

  • fledurfledur Fort Lauderdale, FLPosts: 77Member

    i5 2500k stock clock, 8 Gb RAM, GTX 560Ti

    I run GW2 smooth maxed (only shadows turned off) and I'm always at FPS cap (60 with FPS limiter). FPS only drops to 30-35 in heavy WvW and sometimes to 20 or so when fighting Stonemist's keep lord.

    I'm not even using the latest GPU driver...

  • aznxdreadfulaznxdreadful seattle, WAPosts: 21Member

    I get 120 FPS , in zones that arent crowded. but in things like WVWVW and dynamic events I get 40 fps avg.

    on all high settings ULTRA with super sampling, and my nvidia control panel is maxed everything with nvidia Inspector to make a custom option for HIGH Quality Occulision.

     

     

    i7 3930 , gtx 680, 16gb ram, Asus VG278H monitor.

  • adaneshadeadaneshade Bryant, ALPosts: 36Member
    Originally posted by Masa1
    Originally posted by FuryV

    For crying out loud, stop living in the past.  You already admitted it, your PC sucks.  Don't blame the game.  I've got the game on full graphics with a steady 60 FPS, using a mid range system.  You ripped yourself off by not upgrading your PC, it's not ANET's fault in the slightest.

     

    It's your's.

    I could upgrade... but every other modern game works with max FPS. It's ONLY GW2 which works so badly. Why spend 1500€ for 1 game? It's GW2s fault.

    What games are you playing that are newer than GW2 praytell? Multiplayer with massive amounts of particle effects to boot......

  • ZuvielifyZuvielify Fremont, CAPosts: 168Member

    Every time I look, I'm over 60fps on max settings

     

    i5 3570k, gtx 570

  • TsaboHavocTsaboHavoc PinheiralPosts: 351Member
    how about of helping the guy instead of " my *ick is bigger than yours at max get a e-pe*n" clearly the game in current state is poorly optimized for amd users.
  • TorgrimTorgrim GothenburgPosts: 2,088Member
    Originally posted by TsaboHavoc
    how about of helping the guy instead of " my *ick is bigger than yours at max get a e-pe*n" clearly the game in current state is poorly optimized for amd users.

     

    Did you understand the thread question?

    Did you read thrue the whole 15 pages?

     

    If it's not broken, you are not innovating.

  • MindTriggerMindTrigger La Quinta, CAPosts: 2,596Member

    I'm well over 60 most of the time, and I hang out at 80-100 fps much of the time.  This is with all settings maxed.

    However, I just built a disgusting sli rig using 670s.  My fans don't even spool up for this game.

     

     

    A sure sign that you are in an old, dying paradigm/mindset, is when you are scared of new ideas and new technology. Don't feel bad. The world is moving on without you, and you are welcome to yell "Get Off My Lawn!" all you want while it happens. You cannot, however, stop an idea whose time has come.

  • TsaboHavocTsaboHavoc PinheiralPosts: 351Member
    Originally posted by Torgrim
    Originally posted by TsaboHavoc
    how about of helping the guy instead of " my *ick is bigger than yours at max get a e-pe*n" clearly the game in current state is poorly optimized for amd users.

     

    Did you understand the thread question?

    Did you read thrue the whole 15 pages?

     

    so he asked to see, my bad, only hope is wait for fix on amd side users

  • BrizlynBrizlyn Ladera Ranch, CAPosts: 70Member Uncommon

    I get 60-120+ fps on max settings everywhere in gw2.  

    Wife gets 50-80 fps on max settings.

    gtx680 and gtx560 respectively.

  • MetentsoMetentso BarcelonaPosts: 1,436Member Common
    Let's remember all the guys that bought a new computer or upgraded to play Age of Conan.
Sign In or Register to comment.