Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

GW2 Launch Failure

MouthMouth BergenPosts: 113Member

I simply cannot log in - my request doesnt even reach authentication. I heard from my friend who was able to log in really early this morning that the game is laggy as hell.

Not going to score the game on this, but so far ... extremely bad of course. Going back to The Secret World (which had a 10/10 launch) for a while, but itching to try GW2 ( though I don't think I will like the cartoony "little mouse characters" things, but we'll see). I loved gw1 to bits, but have a bad feeling about gw2 - especially now after tsw launch.

«13456712

Comments

  • SuperXero89SuperXero89 Amory, MSPosts: 2,544Member Uncommon
    Just give it a few hours.  I probably won't even be able to log in until Sunday.  By then I'm sure all the major kinks will be worked out.
  • whaviswhavis Vicksburg, MSPosts: 3Member
    Just logged off bout to get some sleep. I had no problems logging in or with any lag. A friend of mine had a little lag but also no problems logging in. I would give this launch so far a 10/10.
  • ReizlaReizla AlkmaarPosts: 3,300Member Uncommon
    Quite the impatient one, posting this 43 seconds AFTER launch aren't we..?

    AsRock 990FX Extreme3
    AMD Phenom II 1090T ~3.2Ghz
    GEiL 16Gb DDR3 1600Mhz
    ASUS GTX970 3x HD monitor 1920x1080

  • AmjocoAmjoco Layton, UTPosts: 4,778Member Uncommon

    Just logged out and my family and I had a blast on Sanctum of Rall. Overflows were working as advertised. We had no lag but portals were occasionally clogged with people trying to get through! :) 

    I wish I could play more but my eyes are falling out!

    Death is nothing to us, since when we are, Death has not come, and when death has come, we are not.

  • WolfynsongWolfynsong Fort Wayne, INPosts: 237Member
    I had zero issues logging in or with lag.  The only issue I had was that the human tutorial boss didn't advance me properly after I killed it... three times... so I was kind of stuck for a bit.
  • Rider071Rider071 Utica, NYPosts: 318Member

    just throwing this out there for I am at work and cannot check for sure, but it seems a good amount of people are not experiencing any problems, but there a some that are.

     

    something to ponder for you, nvidia and amd both released huge driver updates this week in anticipation of this game, also java and acrobat/adobe did as well yesterday. When was the last time you checked for updates on you computers?

  • ZadawnZadawn SPosts: 651Member
    Otashi,or else?

    image
  • YaosYaos Franklin, TNPosts: 153Member
    I had no problem logging in and there's no lag [mod edit]
  • FadedbombFadedbomb Aiken, SCPosts: 2,081Member
    Originally posted by Reizla
    Quite the impatient one, posting this 43 seconds AFTER launch aren't we..?

    Servers have been up for 3hrs?

    The Theory of Conservative Conservation of Ignorant Stupidity:
    Having a different opinion must mean you're a troll.

  • MouthMouth BergenPosts: 113Member
    was able to log in after several tries, and it is NOT laggy right now - so things were not as bad as i was afraid of
  • seridanseridan ThessalonikiPosts: 1,202Member Uncommon

    From facebook:

    If you're playing from EU, we are investigating the login issues. ~RB2

     

    I haven't experienced any game lag but chatting takes ages :D

    Block the trolls, don't answer them, so we can remove the garbage from these forums

  • ScalplessScalpless SnowballvillePosts: 1,396Member Uncommon

    GW2 is much more popular than TSW was when it launched. This can't be compared to a launch that was most likely way below Funcom's expectations customers wise.

    I admit I expected this to go a bit better, but really, popular MMOs always launch like this. It seems EU servers are having some login isues on top of being full, so I'm not expecting to play much today.

  • ReizlaReizla AlkmaarPosts: 3,300Member Uncommon
    Originally posted by Fadedbomb
    Originally posted by Reizla
    Quite the impatient one, posting this 43 seconds AFTER launch aren't we..?

    Servers have been up for 3hrs?

    Official launch was midnight Pacific time or 9.00 CEST. OP posted it 43 seconds after OFFICIAL launch...

    AsRock 990FX Extreme3
    AMD Phenom II 1090T ~3.2Ghz
    GEiL 16Gb DDR3 1600Mhz
    ASUS GTX970 3x HD monitor 1920x1080

  • NadiaNadia Canonsburg, PAPosts: 11,866Member Common
    i played for 3hrs - had fun and no lag - but im off to bed!
  • ShTogoodShTogood southend on seaPosts: 46Member

    Some EU players are having problems logging in Anet have allready tweeted about it and are working on it.

    In the same boat, was playing fine no lag at all then DC'ed and now i cant log in lol.

    Just love MMOs :)

  • MikeJezZMikeJezZ HillerødPosts: 1,197Member
    Originally posted by Mouth

    I simply cannot log in - my request doesnt even reach authentication. I heard from my friend who was able to log in really early this morning that the game is laggy as hell.

    Not going to score the game on this, but so far ... extremely bad of course. Going back to The Secret World (which had a 10/10 launch) for a while, but itching to try GW2 ( though I don't think I will like the cartoony "little mouse characters" things, but we'll see). I loved gw1 to bits, but have a bad feeling about gw2 - especially now after tsw launch.

    The reason TSW probably had a better launch was because no one bought it.

    Playing ATM: Elder Scrolls Online, Diablo 3
    MMO's shelted: Check my mmorpg profile
    KICKSTARTED: Camelot Unchained. (250 USD)

  • MightyUncleanMightyUnclean st. pete, FLPosts: 706Member Uncommon
    Originally posted by Otashi
    May the trollers, whiners, impatient ragers and all that kind of people rot in hell, seriously we don't want your kind of people in if you don't like it don't buy it and go play TSW...

    Rot in hell?  Wow, Otashi, that's a nice sentiment...Very compassionate.

  • Bad.dogBad.dog Belleville, ONPosts: 1,108Member
    No lag no problem with anything ...NA server
  • everlandeverland EverlandPosts: 71Member
    Who would take seriously someone who says "GW2 launch is a failure", because it is not working for him? It's sounds so childish.
  • MisarisMisaris Cougartown, NEPosts: 140Member

    called a friend to mock him a little (he's a guildwars fan) and he is mad as hell about a "horrendous lag" as he put it.

    Seems like trouble in paradise?

  • Bad.dogBad.dog Belleville, ONPosts: 1,108Member
    Originally posted by Misaris

    called a friend to mock him a little (he's a guildwars fan) and he is mad as hell about a "horrendous lag" as he put it.

    Seems like trouble in paradise?

     Good try ...the friend part gives it away

  • rykim86rykim86 winnipeg, MBPosts: 236Member
    Had no problems logging in, character creating and just generally playing.  Was a few bit of lag spikes here and there, but overall, best MMO launch yet.
  • LydonLydon Cape TownPosts: 2,913Member Uncommon
    No problems patching, no problems logging in, no lag in the slightest for me...

    image
  • ComanComan Hattem, AKPosts: 2,032Member Uncommon
    Originally posted by Reizla
    Quite the impatient one, posting this 43 seconds AFTER launch aren't we..?

    It's 43 minute now after launch and still the same though, but still far from calling it a failure though....I think they should award us some free play time!!!!!

  • IstrebiteIIstrebiteI SpbPosts: 266Member
    Well, cannot log in still :(
«13456712
Sign In or Register to comment.