Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Why do companies insist on....

xenogiasxenogias warsaw, INMember Posts: 1,926

retarted installers/launchers for thier games? This webzen "hub" thing is not only irritating but broken. I keep getting spammed to install adobe flash player....uh it is and up to date. I try to play and it wants me to download some installer....uh already installed your client. Cant get past either of thoes and the "help" section is about as usefull as a pile of dog shit. When will these companies learn that yea, I may be willing to try thier game. Yea I may like it and spend money on it. But no, I'm not going to hassle with broken installers/launchers.

Comments

  • friednietzfriednietz The Study, NYMember Posts: 118

    I had a similar situation; same thing with the C9 hub, being told my flashplayer was out-of-date though it wasn't and being encouraged to used a third party-installer (which you shouldn't dl btw).

    My main problem tho was that I saved the client to my a C:Program folder but the game client didn't show up in the folder. I also couldn't find the client when I did a window's search for it in the C:Program folder that I saved it to.

    Then I tried searching for it using the start menu's search by typing "global" and it showed up and I deleted it.

    I then redownload the client and saved it to my Downloads folder instead of a C:Program folder ans was then able to install and play the game without further problems. Also, make sure to save a short-cut to desktop to eliminate anymore frustrations.

     

    Must say though this is the weirdest install I've ever experienced. It felt at some points that I was installing things in order to install things in order to install things. lol

  • blkwltz19blkwltz19 Bellingham, WAMember Posts: 18 Common

    Yah, i was fine with it until it launched nearly everytime I opened my browser in general (not just for C9). I deleted the main 'overwolf' folder, and it persisted to launch! Went through windows program uninstall, still launched. Finally searched for the exe and got rid of it for good. It's not needed for C9 to work, as it's a third-party add-on.

  • CickoCicko HerningMember Posts: 12 Uncommon

    Have u tried starting it up through internet explore?

    should make extra files easy to install and u should be able to use different browser after the first time

Sign In or Register to comment.