Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

MMORPG.com will be down for maintenance beginning at midnight EST on Tuesday, August 30. Downtime is expected to last only a couple of hours.

TERA-EU website bugged? Help

ElikalElikal ValhallaPosts: 7,912Member Uncommon

Ok I preordered TERA, made an account, but the website of Tera Europe seems to be extremely buggy. I tried both IE and Firefox, but so many errors. I just could not enter my preorder key from Amazon.

Any help or info?

People don't ask questions to get answers - they ask questions to show how smart they are. - Dogbert

Comments

  • XasapisXasapis VolosPosts: 5,512Member Uncommon

    I just tried logging in into the EU Tera account and it works.

  • NBlitzNBlitz ZwollePosts: 1,904Member

    So many errors? What kind of errors? Pretty vague descriptions with which to work with.

    Try this in the mean time: clear your cookies for that particular website. Clear your cache too. Ctrl+F5 while on the website to force refresh. 

  • ElikalElikal ValhallaPosts: 7,912Member Uncommon

    Ok, the first problem is solved now. I had an issue trying to register, many times when I submitted, the page just showed a default browser error website. Like when a website is down or so.

     

    Finally I was able to register my Amazon key. Now when I download, and type my email, password and chose the language, the center of the field goes blank, and looks like this, endlessly. When I close the launcher, it does the same again:

    People don't ask questions to get answers - they ask questions to show how smart they are. - Dogbert

  • XasapisXasapis VolosPosts: 5,512Member Uncommon

    I think I know what it is. That window is where you input your login and password, but you don't get the fields for some reason. Which browser are you using?

    Edit: Is that actually a browser or the game's launcher? If it's the game's launcher you get that error because the EU servers are down.

    Edit 2: Nop, tried it with the game launcher, worked fine, I'm inside. I mean I'm past that message, EU servers are down obviously.

    Edit 3: when I hit Play, I get a general error message popup window (the one you get because servers are down).

  • NBlitzNBlitz ZwollePosts: 1,904Member

    That's the game's launcher. What's your anti-virus doing at that time? Is that a pop-up of it?

  • ElikalElikal ValhallaPosts: 7,912Member Uncommon

    Originally posted by NBlitz

    That's the game's launcher. What's your anti-virus doing at that time? Is that a pop-up of it?

    No popup, I was just looking if I had to add it to exceptions, but it seems to be allowed alright. But I don't really know much about that software.

    People don't ask questions to get answers - they ask questions to show how smart they are. - Dogbert

  • ElikalElikal ValhallaPosts: 7,912Member Uncommon

    Originally posted by Xasapis

    I think I know what it is. That window is where you input your login and password, but you don't get the fields for some reason. Which browser are you using?
    Edit: Is that actually a browser or the game's launcher? If it's the game's launcher you get that error because the EU servers are down.
    Edit 2: Nop, tried it with the game launcher, worked fine, I'm inside. I mean I'm past that message, EU servers are down obviously.
    Edit 3: when I hit Play, I get a general error message popup window (the one you get because servers are down).

    Hm, any info when the EU servers will be up again? =)

    And no, its the launcher not a browser window. It kinda irritates me that there isn't even a message like "Login not accepted" or "servers are down" or what, just endlessly this blank window. :/

    EDIT: I had shut down the firewall in the login process, and it works. It started downloading now. Weird. I must admit I have NO clue how to add this to my firewall. >.< But the loooong download started. yey me. XD

     

    Thanks all for looking into this. ^^

     

    ... Oh man 2 days download it says! *sweatdrop* Damn my old DSL2000 with ~150kb/s :(

    People don't ask questions to get answers - they ask questions to show how smart they are. - Dogbert

  • XasapisXasapis VolosPosts: 5,512Member Uncommon

    It's not blank for me. Sec

    What I get is this:

    Sorry don't have a picture editing software to crop it.

    Looks like the forums don't like my pasted image.

  • XasapisXasapis VolosPosts: 5,512Member Uncommon

    Well, you're in for a visual treat, so it's worth it. Currently easily the best looking mmorpg out there.

    You have a week to download it anyway. Next event is next week if not mistaken.

    https://forum.tera-europe.com/showthread.php?t=27286

  • ElikalElikal ValhallaPosts: 7,912Member Uncommon

    Originally posted by Xasapis

    Well, you're in for a visual treat, so it's worth it. Currently easily the best looking mmorpg out there.
    You have a week to download it anyway. Next event is next week if not mistaken.
    https://forum.tera-europe.com/showthread.php?t=27286

    Having seen videos I am greatly looking forward to it. I am a very visual person and will enjoy the lush world. :)

    People don't ask questions to get answers - they ask questions to show how smart they are. - Dogbert

  • ElikalElikal ValhallaPosts: 7,912Member Uncommon

    Sigh, today I have the same issue. I can't login to continue downloading. Even tho I deactivate the firewall temporary. :((

    People don't ask questions to get answers - they ask questions to show how smart they are. - Dogbert

  • NBlitzNBlitz ZwollePosts: 1,904Member

    Originally posted by Elikal

    Sigh, today I have the same issue. I can't login to continue downloading. Even tho I deactivate the firewall temporary. :((

    What about your antivirus? Just to try.

  • ElikalElikal ValhallaPosts: 7,912Member Uncommon

    Originally posted by NBlitz


    Originally posted by Elikal


    Sigh, today I have the same issue. I can't login to continue downloading. Even tho I deactivate the firewall temporary. :((

    What about your antivirus? Just to try.

    Hmpft, after ~20 minutes trying again and again, it finally worked. No clue why.

    People don't ask questions to get answers - they ask questions to show how smart they are. - Dogbert

Sign In or Register to comment.