Dark and Light: More Beta Testimonials

AdminAdmin Santa Fe, NMAdministrator RarePosts: 5,432

NPCube has posted more testimonials and screen shots from their beta testing community.  I can tell you from first hand experience that the world in Dark and Light is beautiful and rich.  We hope to be bringing you a beta preview real soon ;)


- MMORPG.COM Staff -

- MMORPG.COM Staff -

The dead know only one thing: it is better to be alive.

Comments

  • SupergohanSupergohan ZwolleMember CommonPosts: 54

    There is a video made by beta players. Click on this link: http://www.malefice.org/index.php?lien=videos, scoll down and click on one of the green buttons. (not on the site link next to it)

    This is a French site and the file is about 58 Mb, but worth it!!

    You aint much, if you aint Dutch
    www.mmozone.nl
    image

  • ArgorianArgorian LiegeMember Posts: 2
    this will be a great game !

  • stephen_sofstephen_sof Oak Harbor, OHMember Posts: 388
    yea it will be a great game cant wait until open beta :P

    image
    "It's the darkness that brings us power"
    SOF site come join

    "It's the darkness that brings us power"

  • CandarayCandaray New Smyrna Beach, FLMember Posts: 9

    I went to thier site today to take a look at the game and thought it looked really cool and was interested in signing up for the beta. Alas the link to the beta signups and the community cannot be displayed. Anyone else have this problem??

     

  • stephen_sofstephen_sof Oak Harbor, OHMember Posts: 388
    ive heard of a problem of some people getting to www.darkandlight.com but not the beta sign-up on www.darkandlight.net

    image
    "It's the darkness that brings us power"
    SOF site come join

    "It's the darkness that brings us power"

  • CandarayCandaray New Smyrna Beach, FLMember Posts: 9
    Hmm thats wierd, I can get the .com just fine but .net just won't load. Take it you can get to .net just fine then huh?

  • cedoricedori Hurst, TXMember Posts: 500
    I was on both yesterday and had no problems, it might have to do with server load.  Its happened to me before, but yesterday was fine.

Sign In or Register to comment.