Win 10 sleep not working

DarLorkarDarLorkar Texarkana, TXMember UncommonPosts: 1,082
I have set my new system up with the sleep and hibernate both added to my power button in start. Pushing either of them there and my system goes straight to sleep/hibernate, and stays there.

But i setup a power plan like i had my old win 7 system and the only things that works are the screensaver, and the shutdown monitor. 

Never seems to sleep nor go into hibernate at all that i can see.

I have played around with it setting the times to like 1 minute on both sleep and hibernate and waited but nothing happens.

Been scouring the web but i have not seen anything  (that worked for me at any rate)  that has presented an idea to get it working. Anyone ran into anything along these lines on using win 10 before?

Comments

  • DarLorkarDarLorkar Texarkana, TXMember UncommonPosts: 1,082
    edited April 27
    Well, i got it working, guess no one else had any issues like this. I was getting ready to just not use  a workgroup at all,  since any time i made one it started this no sleep thing again.

    But it turned out an old work around from back with win 7 still works, it just was not explained well from my reading so i was thinking it was not working.

    "This solution from another thread has been working fine for me for several days now:Run the DOS command powercfg /requestsoverride driver srvnet system as administrator.

    Powercfg will still show the client requests but they will not prevent sleep."

    That last part was the tricky part, i was expecting the requests to stop, not just block them from running after a request. So i always thought it was not working after still seeing the requests. as shown next.

    The following commands all ran from an advanced (admin) command prompt. 

    C:\Windows\system32>powercfg -requests
    DISPLAY:
    None.

    SYSTEM:
    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.

    AWAYMODE:
    None.

    EXECUTION:
    None.

    PERFBOOST:
    None.

    ACTIVELOCKSCREEN:
    None.

    With this being the problem causing the no sleep.
    SYSTEM:
    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.

    This keeps my comp from sleeping on auto from a power plan but it will sleep if you reboot and not login to comp or if you do it manually just not from any plans.



    powercfg -requests  checks for running requests

    POWERCFG -REQUESTSOVERRIDE    check for any requests being blocked (like the one below will return this under driver,  srvnet SYSTEM )

    C:\Windows\system32>POWERCFG -REQUESTSOVERRIDE[SERVICE]
    [PROCESS]
    [DRIVER]srvnet SYSTEM
    powercfg /requestsoverride driver srvnet system     command that worked for me  (again you will see the requests still, but they are being blocked )

    powercfg /requestsoverride DRIVER srvnet     use to remove the above command if you wish

    Well that is the end i hope:) working ok so far. Just putting solution that worked for me here in case anyone does run across this issue.









    Post edited by DarLorkar on
  • RidelynnRidelynn Fresno, CAMember EpicPosts: 6,013
    edited April 27
    Mine hasn't been able to sleep for ... a long time now. I don't actually use "sleep", but it is nice to at least have the monitors turn off. They won't even do that.

    Powercfg says it's srvnet, but the fix you got to work doesn't work on my system, for whatever reason. I was going to post that there's some powercfg stuff out there, but being as it did exactly crap for me, I didn't... sorry.

    I'd heard that being part of a homegroup can do this as well, but my system isn't part of a homegroup, so idk wtf. If I disconnect my ethernet, it will let the monitors sleep but then I also lose the ability to do softare updates over night, so... I just turn my monitors off and on by hand... Yay Microsoft.

    Good info though - glad it worked out for you.
    Post edited by Ridelynn on
  • DarLorkarDarLorkar Texarkana, TXMember UncommonPosts: 1,082

    Ridelynn said:

    Mine hasn't been able to sleep for ... a long time now. I don't actually use "sleep", but it is nice to at least have the monitors turn off. They won't even do that.

    Powercfg says it's srvnet, but the fix you got to work doesn't work on my system, for whatever reason. I was going to post that there's some powercfg stuff out there, but being as it did exactly crap for me, I didn't... sorry.

    I'd heard that being part of a homegroup can do this as well, but my system isn't part of a homegroup, so idk wtf. If I disconnect my ethernet, it will let the monitors sleep but then I also lose the ability to do softare updates over night, so... I just turn my monitors off and on by hand... Yay Microsoft.

    Good info though - glad it worked out for you.


    Ya things like this that just affect a few( in total numbers compared to all users) are such a PITA for those of us that are affected.

    Wish it had helped you too. I really hate for my comp not to do what i want it to, when i want it to.
  • TorvalTorval Member LegendaryPosts: 14,154
    Sleep has never worked well for me. My desktop will sleep now, but if I put it in sleep mode it takes 2 to 3 times to shut it down. I'll tell it to shut down but it reboots instead. 

    I keep getting disconnected from the home group. I wonder if they're related now. 

    I've tried to get sleep working so LogMeIn can wake my home system. LMI isn't doing that yet. 
  • MadFrenchieMadFrenchie Nashville, TNMember EpicPosts: 2,243
    edited April 27
    Mostly unrelated but I've had an issue with my PC where it won't stay shut down.  I had to disable the fast boot option (or some similar sounding boot feature) to prevent my PC from rebooting itself every time I try to shut it down.

    Software's weird, yo.
    Post edited by MadFrenchie on

    image
  • RidelynnRidelynn Fresno, CAMember EpicPosts: 6,013
    And @cheyane thinks it's weird that all her computer does is double boot.
  • DarLorkarDarLorkar Texarkana, TXMember UncommonPosts: 1,082

    Ridelynn said:

    And @cheyane thinks it's weird that all her computer does is double boot.


    Heh yup.
Sign In or Register to comment.