Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

Has Trion explained why Rift now has crappy frame rates?

BarCrowBarCrow Tampa, FLPosts: 2,212Member

I had a good year of enjoying this game and thought I'd go back. I had Gtx 275 when the game launched....and it was packed during launch and for a while after. I regularly attained 39-50 fps ( down to maybe 20 fps in busy cities) with almost everything on highest setttings. Ambient occlusion off.

Now..I go back and i have a better PC with an upgrade in Ram CPU, Motherboard and a Gtx 580 with 1gb . Same basic settings as before as I never deleted it from my hard drive. I get about 20 fps just about everywhere with occasional spikes down to around 7fps or so or up to 35-49 then right back down to the still shitty 20 fps range or less . Anyone have a clue why? Or has Trion just completely f*cked over their engine optimization?

Comments

  • maple2maple2 HerningPosts: 93Member

    Rift got a really bad Engine that is not supporting the players it has..

     

    even top Cards like Titan, Gtx 780 and so on R9 280X can't get more then 30-40 fps maxed out 

  • BarCrowBarCrow Tampa, FLPosts: 2,212Member
    Originally posted by maple2

    Rift got a really bad Engine that is not supporting the players it has..

     

    even top Cards like Titan, Gtx 780 and so on R9 280X can't get more then 30-40 fps maxed out 

    Well that sucks. Honestly my GTX 275 looked better...even in the 25-45 fps range it seemed smooth and for the most part unnoticeable . Now..even during the minute or so that I occasionally get around 49 fps..its seems choppy. A drastic change from launch imo.

    I would go play Guild Wars 2 instead but I hate that you can't see players in busier areas until they enter the 20 ft radius around your avatar then just pop into sight. I was told they fixed that for PvP and  thought  they were going to fix that for PvE areas as well...but here..a year later...nothing.

  • Professor78Professor78 TamworthPosts: 588Member
    I would say that installing new hardware without formatting could always give you probs, i would recommend a full OS install, and then rift again - you will find a lot of old cache is cleared that you can't manually do.

    Core i7(d0)on Foxconn Bloodrage, 6gb Tri DDR3,GTX 680, 120gb OCZ Vertex 2 SSD, 640gb Caviar Black, Windows 7, HAF 932 case, 24" Full HD Dell, Logitech G19, Rat 9, 50mb BB.

  • DMKanoDMKano Gamercentral, AKPosts: 8,506Member Uncommon

    Rift runs way smoother for me than FF14ARR. 

    i7, 670GTX, 16GB ram, SSD, 1920x1200 IPS

    The *key* issue to getting awesome performance in Rift with nVidia is forcing all the performance setting via nVidia control panel (FXAA etc..) Do not let the application (Rift) control GPU settings. Not only will your game run a lot better, it will look better too.

    Don't get me wrong both games run well, but with 50+ people on screen Rift is smoother on my system.

    As a final note I play both games on max settings in game (use nVidia control panel to force best performance for Rift)

     

  • BarCrowBarCrow Tampa, FLPosts: 2,212Member
    Originally posted by DMKano

    Rift runs way smoother for me than FF14ARR. 

    i7, 670GTX, 16GB ram, SSD, 1920x1200 IPS

    Don't get me wrong both games run well, but with 50+ people on screen Rift is smoother on my system.

    As a final note I play both games on max settings.

    Well you have a better card ,more ram and ,even at a higher resolution, I can understand why your's is running better than mine. But I can't fathom why my current setup is running worse than my old build. It might be the connecting paths  to the server that are gang-bangin' me with big ole' lag spikes.. Idk.

    I'll try the forced settings through Nvidia ..thanks for reminding me of that. I know when I did that with a few games...e.g  AoC and Fallen Earth...it was like night and day. Providing it is mainly graphic lag and not some other interference.

  • gigatgigat Minneapolis, MNPosts: 604Member Uncommon
    Originally posted by BarCrow

    I had a good year of enjoying this game and thought I'd go back. I had Gtx 275 when the game launched....and it was packed during launch and for a while after. I regularly attained 39-50 fps ( down to maybe 20 fps in busy cities) with almost everything on highest setttings. Ambient occlusion off.

    Now..I go back and i have a better PC with an upgrade in Ram CPU, Motherboard and a Gtx 580 with 1gb . Same basic settings as before as I never deleted it from my hard drive. I get about 20 fps just about everywhere with occasional spikes down to around 7fps or so or up to 35-49 then right back down to the still shitty 20 fps range or less . Anyone have a clue why? Or has Trion just completely f*cked over their engine optimization?

    Just to clarify, you upgraded RAM, CPU, motherboard and GPU, but didn't format your hard drive and reinstall the OS?

    If that's the case, I'm surprised you can boot into Windows, let alone play a video game.  Normally replacing the motherboard will invalidate your Windows license (which sometimes isn't an issue, depending on which version and how many times it's been activated, or your new motherboard is the same (or similar) model as your old motherboard).  Also, driver issues might occur when swapping hardware.  Considering how many components you swapped out, you're lucky you can even boot into Windows.

     

    If you really didn't format the hard drive and reinstall the OS, then I recommend doing that right now if you're still having performance issues.

    "Lose the helmet sis, we can't prove that you're retarded." - Dennis Reynolds

  • xanthmetisxanthmetis Racine, WIPosts: 135Member
    It was funny about 6 months ago i redownloaded the game and was lagging so hard.  In pvp I wouldnt even see my attackers before they were closing in on me.  It was not like that at release.  I have a better machine than I did at release and have zero issues in any other game I play.  Glad it wasn't be, but sad that trion allowed that to happen.  I actually was thinking about getting back into the game six months ago until that occurred.

    image
  • XeonsoldierXeonsoldier Atlanta, GAPosts: 190Member
    Best thing you can do is overclock the nonsense out of your CPU and level the spell particles.
  • fivorothfivoroth LondonPosts: 3,661Member Uncommon
    Rift's engine is horrible. It's not optimised and the animations are horrible. 

    Mission in life: Vanquish all MMORPG.com trolls - especially TESO, WOW and GW2 trolls.

  • Swedish_ChefSwedish_Chef of heroes, MSPosts: 213Member
    It's because Rift's engine is a buggy, unoptimized mess. Always has been, and most likely always will be.
  • CalmmoCalmmo LondonPosts: 52Member

    Most of you dont even rift, that much is obvious, performance is 100% cpu limited (tho im sure some here are proly coming to QQ after trying to run the game on something stupid like a GT 220)

    AKA complete lack of multicore/multithread support. They claim 2.5 will have "significant" performance upgrades, so maybe they are adding it. Then again, I highly doubt it. They promised 2.4 would bring part 1 of that, and all they did was add an option to reduce the number of actual pixels rendered at any given resolution. aka make the game look like something from the 90s.

     

    Unless you have a top end rig and are willing to accept framerate that will be slightly above "playable" look elsewhere rift maybe isnt a resource hog but that is only because it cant even utilize 3/4 of your hardwares resources

  • PanzerbasePanzerbase Chicago, ILPosts: 423Member
    It's running just fine for me, but really thanks for thinking you spoke for everyone. 
  • DMKanoDMKano Gamercentral, AKPosts: 8,506Member Uncommon
    Originally posted by Swedish_Chef
    It's because Rift's engine is a buggy, unoptimized mess. Always has been, and most likely always will be.

    False - its an old engine but it has gone through a lot of changes since release.

    After I haredcoded my nvidia settings to override application settings - zero issues, actually runs a lot better than many other games with 50+ players on screen.

     

  • saurus123saurus123 nonePosts: 568Member Uncommon
    Originally posted by BarCrow
    Originally posted by maple2

    Rift got a really bad Engine that is not supporting the players it has..

     

    even top Cards like Titan, Gtx 780 and so on R9 280X can't get more then 30-40 fps maxed out 

    Well that sucks. Honestly my GTX 275 looked better...even in the 25-45 fps range it seemed smooth and for the most part unnoticeable . Now..even during the minute or so that I occasionally get around 49 fps..its seems choppy. A drastic change from launch imo.

    I would go play Guild Wars 2 instead but I hate that you can't see players in busier areas until they enter the 20 ft radius around your avatar then just pop into sight. I was told they fixed that for PvP and  thought  they were going to fix that for PvE areas as well...but here..a year later...nothing.

    well good news for you they removed the culling from PVE and PVP in GW2 you can see all the players :)

    or you can set it in options to not show all of them to keep your fps high enough :)

  • ArthasmArthasm LoznicaPosts: 754Member Uncommon
    Crappy engine. Only had problem running it on laptop, On high/ultra settings I had 10-20 fps, on everything low - same. OP, google tweaks for Rift, maybe will help you. It worked for me. But, still their engine is light years better than SWTOR...
  • BarCrowBarCrow Tampa, FLPosts: 2,212Member
    Originally posted by gigat
    Originally posted by BarCrow

    I had a good year of enjoying this game and thought I'd go back. I had Gtx 275 when the game launched....and it was packed during launch and for a while after. I regularly attained 39-50 fps ( down to maybe 20 fps in busy cities) with almost everything on highest setttings. Ambient occlusion off.

    Now..I go back and i have a better PC with an upgrade in Ram CPU, Motherboard and a Gtx 580 with 1gb . Same basic settings as before as I never deleted it from my hard drive. I get about 20 fps just about everywhere with occasional spikes down to around 7fps or so or up to 35-49 then right back down to the still shitty 20 fps range or less . Anyone have a clue why? Or has Trion just completely f*cked over their engine optimization?

    Just to clarify, you upgraded RAM, CPU, motherboard and GPU, but didn't format your hard drive and reinstall the OS?

    If that's the case, I'm surprised you can boot into Windows, let alone play a video game.  Normally replacing the motherboard will invalidate your Windows license (which sometimes isn't an issue, depending on which version and how many times it's been activated, or your new motherboard is the same (or similar) model as your old motherboard).  Also, driver issues might occur when swapping hardware.  Considering how many components you swapped out, you're lucky you can even boot into Windows.

     

    If you really didn't format the hard drive and reinstall the OS, then I recommend doing that right now if you're still having performance issues.

     As far as windows 7..when I called microsoft / windows support they help me activate windows again on the new system. I have done this before in the past. I had copies of my files and settings ( for many games and commonly used programs) on an external drive...I did format the new drive (which I didn't mention getting..sorry) then transferred everything over. I know its a backward ass way and not the best but it was a way not to sit there for hours and download everything again. I've done this a few times with only a few problems....sometimes permissions would get messed up and I'd have go and make adjustments, reconfigure extenders and what not (not really a problem I guess), other setting issues, etc. Other than that I usually experience no severe issues once I get everything situated, perform some tweaks and a registry clean. Especially with gaming.

    Anyway...I forced the graphic settings via Nvidia Control panel and had the target file adjusted to clientport 80 and now I get 45-60 fps most times with 23-35 fps in the city and other populated areas. Thanks for all your suggestions and advice everyone involved and a special shout-out to DMKano for reminding me of something I used to do but completely forgot about. I think that advice was the true game changer. 

    ...and yes I logged onto GW2 again and sure enough...much better..culling mostly unnoticeable and on higher settings (set  to allow the max view) it looks awesome...no pop-up players . I only get 25-45 fps unless I'm alone or in an instance but it still looks fairly smooth with little choppiness .

    Still...I really need a better gpu, the highest end 1155 lga socket cpu i can find , an ssd for OS and a few games and a caviar hd.. Oh well..maybe once I climb out of this hole life has me in for the moment. lol. 

  • fivorothfivoroth LondonPosts: 3,661Member Uncommon
    Originally posted by DMKano
    Originally posted by Swedish_Chef
    It's because Rift's engine is a buggy, unoptimized mess. Always has been, and most likely always will be.

    False - its an old engine but it has gone through a lot of changes since release.

    After I haredcoded my nvidia settings to override application settings - zero issues, actually runs a lot better than many other games with 50+ players on screen.

     

    The engine is so bad that when I got a 4th gen i7, the game actually ran worse (unplayable 25 fps)  than on my Core 2 Duo which makes lots of sense ;D Core 2 Duo > i7.

    Mission in life: Vanquish all MMORPG.com trolls - especially TESO, WOW and GW2 trolls.

  • RabidMouthRabidMouth Charlotte, NCPosts: 196Member

    I tried to pick it up last week and I didn't  notice any fps problems. I had everything on max. Just couldn't enjoy the game. it is missing something

    You can't reason someone out of a position they didn't reason themselves into.

  • nickster29nickster29 Holmen, WIPosts: 486Member
    Originally posted by fivoroth
    Originally posted by DMKano
    Originally posted by Swedish_Chef
    It's because Rift's engine is a buggy, unoptimized mess. Always has been, and most likely always will be.

    False - its an old engine but it has gone through a lot of changes since release.

    After I haredcoded my nvidia settings to override application settings - zero issues, actually runs a lot better than many other games with 50+ players on screen.

     

    The engine is so bad that when I got a 4th gen i7, the game actually ran worse (unplayable 25 fps)  than on my Core 2 Duo which makes lots of sense ;D Core 2 Duo > i7.

    Well, if the individual cores were clocked higher and you had a larger memory cache on the processor, the Core 2 Duo probably would have worked better than the quad core i7 (for Rift anyways).  The CPU always seems to be the bottleneck on Rift for performance.

  • nerovipus32nerovipus32 dublinPosts: 2,735Member
    I don't know how this game got so much exposure it's probably the worst of all the wow clones that i have played. Trion just make terrible games.
  • DMKanoDMKano Gamercentral, AKPosts: 8,506Member Uncommon
    Originally posted by nerovipus32
    I don't know how this game got so much exposure it's probably the worst of all the wow clones that i have played. Trion just make terrible games.

    You just hate Trion - every single thread about Trion you are always posting the same thing, which is fine.

    Rift IMO is far ahead of WoW and is not a WoW clone at all, but you probably haven't played it til lvl 60 to see for yourself, as again you just have an Axe to grind with Trion for some reason.

     

  • rojoArcueidrojoArcueid hell, NJPosts: 6,766Member Uncommon
    Originally posted by DMKano

    Rift runs way smoother for me than FF14ARR. 

    i have a much MUCH inferior PC than yours and i was running ARR with everything on ultra at 40-60fps (50-60 everywhere, and around 40 with many people nearby with the occasional spike in the mid 30s).

     

    With Rift maxed out i get around 30+ (below 40) when im alone, anywhere. If there are people around i get between 15 and 30 with an average closer to 25. Back when i first bought my Radeon HD 6950 my fps didnt go that low, now they do (with the same card).

     

    I dont know what is going on there since many PC with different setups get different performance, but Rift definitelly has gotten worse performance wise.

    image
  • nickster29nickster29 Holmen, WIPosts: 486Member
    Originally posted by rojo6934
    Originally posted by DMKano

    Rift runs way smoother for me than FF14ARR. 

    i have a much MUCH inferior PC than yours and i was running ARR with everything on ultra at 40-60fps (50-60 everywhere, and around 40 with many people nearby with the occasional spike in the mid 30s).

     

    With Rift maxed out i get around 30+ (below 40) when im alone, anywhere. If there are people around i get between 15 and 30 with an average closer to 25. Back when i first bought my Radeon HD 6950 my fps didnt go that low, now they do (with the same card).

     

    I dont know what is going on there since many PC with different setups get different performance, but Rift definitelly has gotten worse performance wise.

    This is the same with me.  I have tweaked Rift to have better performance, but it still comes to a crawl with a high number of people on screen, such as the hunt zone events in the Dendrome... meanwhile on FFXIV my computer seems to handle the higher number counts better.

  • SpellforgedSpellforged Belvidere, ILPosts: 458Member

    Rift always had crappy performance and that hasn't changed.  The issue stems from Rift using a modified version of the Gamebryo engine.  It's complete shit and no decent games have used Gamebyro in the past few years.

    Edit:  I'd also like to confirm that FFXIV: ARR performs better than Rift.  FFXIV looks about 10x better than Rift and has much better performance.

    image
Sign In or Register to comment.