Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

Odd problem? Is it the graphics card?

I just installed my new graphics card ( AMD Radeon 7850 ) and i loaded WoW up again, log back in and i notice..no one is moving, So i checked my latency and Home MS - 0  World MS - 0  Then i would disconnect? I dont know why but im suspecting the graphics card since i had no problems like this till now..

image

Comments

  • ZyzraZyzra Madison, WIPosts: 354Member
    A quick google search leads me to believe there are compatibility issues with that 7850 and WoW.  One person mentioned that some hardware reviews had problems with that card and WoW specifically.  Some even thought the upgrade was good for most games, but got worse with WoW.
  • toolowdown71toolowdown71 elizabethtown, KYPosts: 23Member

    there is alot of problem's with the 7850 not playing nice with wow:( here is one thread

     

    http://us.battle.net/wow/en/forum/topic/6147176646

  • AdamaiAdamai derbyPosts: 469Member
    A few things you can try!


    1. Use older driver and cat suite.
    2. Try the omega series driver with your csrd
    3. Go to the games ini.exe file and tinker with starting resolution settings
    4. Try to run the game in compatibiliry mode with win xp service pack 3.
    5. Check your cat suit settings. Newer cards often tend to work more efficiently in higher res settings useing all the splenders. I know my 7750 does. Its crap at 1024x 768. But epic at 1920x 1080 res with all settings on max. Try diffrent combinations. Also messing with desk top settings can have an impact. Ensure you have all netframeworks!!!

    failing that get an nvidia
  • AdamaiAdamai derbyPosts: 469Member
    A few things you can try!


    1. Use older driver and cat suite.
    2. Try the omega series driver with your csrd
    3. Go to the games ini.exe file and tinker with starting resolution settings
    4. Try to run the game in compatibiliry mode with win xp service pack 3.
    5. Check your cat suit settings. Newer cards often tend to work more efficiently in higher res settings useing all the splenders. I know my 7750 does. Its crap at 1024x 768. But epic at 1920x 1080 res with all settings on max. Try diffrent combinations. Also messing with desk top settings can have an impact. Ensure you have all netframeworks!!!

    failing that get an nvidia
  • ShakyMoShakyMo BradfordPosts: 7,207Member
    Go into AMD cat.
    Change all the settings from let the game decide to manual settings that suit you (you can probably use a nice level of aa and af with your card)
    See if that works.

    If so make a profile for wow, using these new settings, and revert cat to let the game decide settings.

    Less hassle than messing about with old drivers.
Sign In or Register to comment.