Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

AC2 Official Forum Login

MightyUncleanMightyUnclean Posts: 995Member Uncommon

I can't log in to the AC2 forum.  I tried my account login and password and it says it's incorrect.  I tried to register and it just takes me to account management.  What am I missing?

 

Thanks!

 

Comments

  • RasereiRaserei webster, MAPosts: 1,022Member Uncommon

    I had trouble at first also. If I recall correctly, once you buy the game and apply your key, inside your account page at turbine, it will show your Asherons Call subscription. I think there is a button to create a forum avatar. If there isnt, let me know, I'll start a thread over at the AC2 forum and get a better answer.

     

    Servers are hiccuping right now anyways cause the game is getting a HUGE response in players and it's the holidays so yeah.

  • Cochran1Cochran1 Eden, NCPosts: 456Member

    I think you have to set up your forum account through the turbine account management there should be a link to set forum name and password when you log in.

  • MightyUncleanMightyUnclean Posts: 995Member Uncommon
    When I click on Forum Account in the account manager, it just takes me to the main forum.  =/
  • RasereiRaserei webster, MAPosts: 1,022Member Uncommon

    Login here:

     

    http://myaccount.turbine.com/

     

    The main page should have a AC1 subscription. There should be a button to setup a forum account. You dont setup a forum account on the actual forum.

     

    After you set it up, you login to the forum using what you typed in there.

  • MightyUncleanMightyUnclean Posts: 995Member Uncommon
    Originally posted by Raserei
    Login here:   http://myaccount.turbine.com/   The main page should have a AC1 subscription. There should be a button to setup a forum account. You dont setup a forum account on the actual forum.   After you set it up, you login to the forum using what you typed in there.

    Yeah, but when I click on the Forum Account button, it doesn't take me to any kind of management page.  It just directs me to

    http://forums.ac.turbine.com/

    Doesn't give me an option to set up or change a forum name/password.  When I try to login here, I get the error message "You have entered an invalid username or password. Please press the back button, enter the correct details and try again. Don't forget that the password is case sensitive."

    I've made sure I'm in lower case, as my password is.

  • RasereiRaserei webster, MAPosts: 1,022Member Uncommon

    When I login to myaccount.turbine.com I go to a page which says "Activate Product Key" and below that it shows my Asherons Call 1 subscription because I entered the code I got when I bought it. Inside the sub window, it shows my forum name. Before I registered, I believe it had a "setup forum account" option in which I set a password and login. Then I used that on the forums.

     

    EDIT: When you login to the turbine account page, the "Home" tab is the screen I am talking about. If it doesn't show your AC1 sub there, then you need to apply your AC1 product key.

  • MightyUncleanMightyUnclean Posts: 995Member Uncommon

    OK, I chose the option to reset my forum password, and new pw was supposed to be emailed to me.  Didn't happen LOL.

     

    Update:  Nevermind, it just took a while to email!  Thanks for the help, guys.

Sign In or Register to comment.