Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fuzzy Avatars Solved! Please re-upload your avatar if it was fuzzy!

Downloader/Patcher issues

hotfrosthotfrost TwelloPosts: 20Member

Hey there all, I'm an old Age of Conan player and I've always wanted to play TSW too, especially with the new pricing.

 

But... there is one thing that stops me from buying this game, when I was playing Age of Conan the patcher/downloader always was total crap, it downloaded everything superfast with like 9mb/sec but the last few MB's left to download didn't get downloaded, the patcher was just infinitely trying to download at 0 bytes/sec. A few years later when AoC went F2P I gave it another chance and somehow it worked, however there was a patch after I've played for some time and the patcher was stuck forever, again.

 

Now before TSW came out I was invited for beta-testing, I was super excited and downloaded the game's downloader and immediatly i saw it: it is the same launcher as the one of AoC. And guess what, i got the same problem again it downloads super fast except for the last files, it's just infinitely downloading at extremely low speeds again.

Now I really want to play this game but I am NOT wasting my money again.

 

The reason I'm posting here and not on the TSW support forums is because Funcom's support is total sh*t. I've been mailing with their tech supports and sent them dozens of e-mails and got bad responses everytime.

 

My Excuses if there is any bad grammar or english.

 

«1

Comments

  • RocketeerRocketeer NachrodtPosts: 1,304Member

    I did not have any issues with their patcher. I hate to bring this line, but could the issue be on your end? I mean if your seeing it again and again over such a long period of time ...

    I don't see why the content servers should just arbitrarily decide to stop sending you data. Also how would they know its YOU time and time again to bug out(patching happens before login)? To me it sounds like a corrupted installation or something. In other words i don't think it will happen to you on a fresh install, and if it does it should be fixable because it should be on your end and thus under your control.

    Also yeah, support won't be able to help you with that beyond advising a reinstall or telling you to start the patcher as admin. If the rate drops to 0 on your end, yet on their end they see nothing wrong with their servers ... they can't do anything. 

  • hotfrosthotfrost TwelloPosts: 20Member
    Well, I've tried every solution you can imagine, start in adminstrator mode, do a fresh install, disable firewall/anti-virus, disable as much background applications, I even sent them some log files and more in the e-mails. Nothing worked, after a while they just didn't respond to me anymore.
  • revanirevani Who knowsPosts: 8Member

    I'm having some issues with TSW patcher too, but probably of different kind.

    The problem is new for me though. I also played AOC but never had problems there. The thing is, I can't even install the game, for some reason my ClientPatcher.exe crashes every time i try to run it and freezes the entire TSW folder :-D

    I also tried everything i could but nothing helped. Well, almost nothing, but i have no idea if this is possible for you. Well, here it goes anyways.

    I installed the game on different computer  (my laptop), updated it and then copied the entire 40Gb folder on external hard drive and moved it onto my pc. Game now runs without any problems. It even manages to update itself sometimes. But mostly it fails and i have to redo the entire process again :-D (If I let it run, the patcher infinitely runs at 0 bytes/sec, just like yours)

    But i really like the game so i don't mind :-)

    I think this should work for you too, no idea if it's worth the bother or possible for you though :-)

     

    Edit: It really is horrible workaround, so if anyone has any idea what might be tha cause I'd welcome it :-)

     

  • surfer88surfer88 Lansing, MIPosts: 33Member
    just bought it thru steam you may want to try and get it from them instead... and its on sale for like $23
  • platonicxplatonicx CBPosts: 21Member
    Try to run the patcher in safe mode. As in when windows is starting press F8 and choose safe mode. I would be farly amazed if the issue you are describing would happen there aswell.
  • kevjardskevjards carlislePosts: 1,463Member
    Originally posted by hotfrost

    Hey there all, I'm an old Age of Conan player and I've always wanted to play TSW too, especially with the new pricing.

     

    But... there is one thing that stops me from buying this game, when I was playing Age of Conan the patcher/downloader always was total crap, it downloaded everything superfast with like 9mb/sec but the last few MB's left to download didn't get downloaded, the patcher was just infinitely trying to download at 0 bytes/sec. A few years later when AoC went F2P I gave it another chance and somehow it worked, however there was a patch after I've played for some time and the patcher was stuck forever, again.

     

    Now before TSW came out I was invited for beta-testing, I was super excited and downloaded the game's downloader and immediatly i saw it: it is the same launcher as the one of AoC. And guess what, i got the same problem again it downloads super fast except for the last files, it's just infinitely downloading at extremely low speeds again.

    Now I really want to play this game but I am NOT wasting my money again.

     

    The reason I'm posting here and not on the TSW support forums is because Funcom's support is total sh*t. I've been mailing with their tech supports and sent them dozens of e-mails and got bad responses everytime.

     

    My Excuses if there is any bad grammar or english.

     

    personally i have had no probs with the patcher..but i did have with AOC..kept crashing etc..i will say this though. TSW is a very stable game..i have had no crashes at all .the patcher works fine..i would suggest doing it through steam as well if your having probs..or at least check out the game on the forum on steam and see if anyone else is having that type of problem..if not you may want to get it through them..gl sorting it though m8.

    p.s what windows are you running m8..just out of interest..if it is vista then that is why conan is crap..it crashed 16 times on me in 1 hr on godslayer..had to upgrade to w7

  • RusqueRusque Las Vegas, NVPosts: 2,228Member Uncommon
    I've had regular issues with the launcher, it will complete updating and then sit at 0 bps while seemingly exceeding the total download amount.  Luckily all I have to do is exit and relaunch the game and it works. No clue, but it's funcom.
  • hotfrosthotfrost TwelloPosts: 20Member
    Originally posted by kevjards

    personally i have had no probs with the patcher..but i did have with AOC..kept crashing etc..i will say this though. TSW is a very stable game..i have had no crashes at all .the patcher works fine..i would suggest doing it through steam as well if your having probs..or at least check out the game on the forum on steam and see if anyone else is having that type of problem..if not you may want to get it through them..gl sorting it though m8.

    p.s what windows are you running m8..just out of interest..if it is vista then that is why conan is crap..it crashed 16 times on me in 1 hr on godslayer..had to upgrade to w7

    I am running on Windows 7 64-bit.

     

     

    Originally posted by Rusque
    I've had regular issues with the launcher, it will complete updating and then sit at 0 bps while seemingly exceeding the total download amount.  Luckily all I have to do is exit and relaunch the game and it works. No clue, but it's funcom.

    I had the EXACT problem as you but restarting the patcher didn't work, i tried administrator mode and safe mode, everything.

     

     

    Originally posted by revani

    I'm having some issues with TSW patcher too, but probably of different kind.

    The problem is new for me though. I also played AOC but never had problems there. The thing is, I can't even install the game, for some reason my ClientPatcher.exe crashes every time i try to run it and freezes the entire TSW folder :-D

    I also tried everything i could but nothing helped. Well, almost nothing, but i have no idea if this is possible for you. Well, here it goes anyways.

    I installed the game on different computer  (my laptop), updated it and then copied the entire 40Gb folder on external hard drive and moved it onto my pc. Game now runs without any problems. It even manages to update itself sometimes. But mostly it fails and i have to redo the entire process again :-D (If I let it run, the patcher infinitely runs at 0 bytes/sec, just like yours)

    But i really like the game so i don't mind :-)

    I think this should work for you too, no idea if it's worth the bother or possible for you though :-)

     

    Edit: It really is horrible workaround, so if anyone has any idea what might be tha cause I'd welcome it :-)

    I am going to try this, I have a macbook now and a few months ago I didn't so I wasn't able to do this, wish me luck!

  • RocketeerRocketeer NachrodtPosts: 1,304Member
    Originally posted by hotfrost
    Originally posted by revani

    I'm having some issues with TSW patcher too, but probably of different kind.

    The problem is new for me though. I also played AOC but never had problems there. The thing is, I can't even install the game, for some reason my ClientPatcher.exe crashes every time i try to run it and freezes the entire TSW folder :-D

    I also tried everything i could but nothing helped. Well, almost nothing, but i have no idea if this is possible for you. Well, here it goes anyways.

    I installed the game on different computer  (my laptop), updated it and then copied the entire 40Gb folder on external hard drive and moved it onto my pc. Game now runs without any problems. It even manages to update itself sometimes. But mostly it fails and i have to redo the entire process again :-D (If I let it run, the patcher infinitely runs at 0 bytes/sec, just like yours)

    But i really like the game so i don't mind :-)

    I think this should work for you too, no idea if it's worth the bother or possible for you though :-)

     

    Edit: It really is horrible workaround, so if anyone has any idea what might be tha cause I'd welcome it :-)

    I am going to try this, I have a macbook now and a few months ago I didn't so I wasn't able to do this, wish me luck!

    Hmm there is one important thing i would check, which is trying this process through a virtual machine, example paralles(there are free ones aswell that should just as easily work). You could for example create a small virtual partition in a file on your harddrive, and then mount the folder with TSW in it as a harddrive. NOT to run the game, just for the patcher. Linux for example wouldn't require a additional license and the patcher should work through wine.

    I mean it sounds hard, but its actually fun and not that complicated. If you have a old windows license you could also use that ofc. That way you essentially make sure its not on your end since your doing it from a fresh OS install in virtual hardware.

  • hotfrosthotfrost TwelloPosts: 20Member
    Originally posted by Rocketeer

    Hmm there is one important thing i would check, which is trying this process through a virtual machine, example paralles(there are free ones aswell that should just as easily work). You could for example create a small virtual partition in a file on your harddrive, and then mount the folder with TSW in it as a harddrive. NOT to run the game, just for the patcher. Linux for example wouldn't require a additional license and the patcher should work through wine.

    I mean it sounds hard, but its actually fun and not that complicated. If you have a old windows license you could also use that ofc. That way you essentially make sure its not on your end since your doing it from a fresh OS install in virtual hardware.

    Already did all this. But guess what, it didn't work.

    I booted up my windows installation and started the launcher of TSW, everything just downloaded really fast and smooth again but the last it just stopped downloading.

  • Po_ggPo_gg Twigwarren, WestfarthingPosts: 2,714Member Uncommon
    Originally posted by Rusque
    I've had regular issues with the launcher, it will complete updating and then sit at 0 bps while seemingly exceeding the total download amount.  Luckily all I have to do is exit and relaunch the game and it works. No clue, but it's funcom.

    Similar with me, it happens all the time in AoC and with TSW as well. I'm already used to it, maybe it'd be even weird if the patcher suddenly would stop successfully after patching :)

     

    I have the 3rd pc since AoC launch, it happened both under XP and Win7, so I'm pretty sure it's not a client side issue. It's a bit different in my case though, as it only happens after patches, and I don't have the "sitting at 0b/s" part, for me the patcher continues downloading with regular speed. Once I went to eat during a patch, and I came back to somewhere around 5000 / 2100 and still increasing... After I quit the patcher, next time the game launches without error, and keeping that way until the next patch. As I said, it even became the standard for me, since it's happening by every patch :)

    (now tried to remember, and I guess I never saw during the years a "successfully ended" patching in AoC or TSW, I had to quit manually every time after it downloaded everything...)

  • RocketeerRocketeer NachrodtPosts: 1,304Member
    Originally posted by Po_gg
    Originally posted by Rusque
    I've had regular issues with the launcher, it will complete updating and then sit at 0 bps while seemingly exceeding the total download amount.  Luckily all I have to do is exit and relaunch the game and it works. No clue, but it's funcom.

    Similar with me, it happens all the time in AoC and with TSW as well. I'm already used to it, maybe it'd be even weird if the patcher suddenly would stop successfully after patching :)

     

    I have the 3rd pc since AoC launch, it happened both under XP and Win7, so I'm pretty sure it's not a client side issue. It's a bit different in my case though, as it only happens after patches, and I don't have the "sitting at 0b/s" part, for me the patcher continues downloading with regular speed. Once I went to eat during a patch, and I came back to somewhere around 5000 / 2100 and still increasing... After I quit the patcher, next time the game launches without error, and keeping that way until the next patch. As I said, it even became the standard for me, since it's happening by every patch :)

    (now tried to remember, and I guess I never saw during the years a "successfully ended" patching in AoC or TSW, I had to quit manually every time after it downloaded everything...)

    Now that you mention it, it did that for me aswell. But it didn't affect the game, just had to restart the patcher.

  • ZyzraZyzra Madison, WIPosts: 354Member

    Sometimes with The Secret World's patcher the progress will complete but it will still attempt to very slowly download tiny files.  Closing the patcher and reopening it is a very quick and easy fix, as it will quickly check the files and see they have been patched, and let you play.

     

    Why anyone would consider a game a waste of money because the patcher successfully patches the game but they don't want to bother with like three mouse clicks is beyond me.  It isn't even that frequent either, only sometimes when there is a patch.  There isn't always a patch.

     

    I mean what is next, the font in the words Play Game will be a cause to never play the game as its a waste of money?  Give me a break.

  • DakeruDakeru Posts: 1,637Member Uncommon

    Me and friends had similar issues - each time the patcher would keep on patching.

    50mb out of 2.5mb needed or rather file 60 out of 17 files required.

    Funcom - great storylines - shitty programming.

    I have an entitlement delusion - because I have this strange idea that my 50$ should have the same value as anyone else's 50$
    "Your account is not entitled to the same value as a new account. Just saying you are entitled to the same as someone else because you said so is exactly what expresses your entitlement issues."

  • ZyzraZyzra Madison, WIPosts: 354Member

    Yeah when I notice it start to go over the 100% of files, I just close the patcher, relaunch, and play.

    I mean if people can't get past having to take a few extra seconds every few weeks for an additional three mouse clicks and will never buy a game because of that... well more power to ya I guess?

    Me?  I'll continue to enjoy playing the game and not getting worked up over something so incredibly trivial.

  • RocketeerRocketeer NachrodtPosts: 1,304Member
    Originally posted by Zyzra

    Yeah when I notice it start to go over the 100% of files, I just close the patcher, relaunch, and play.

    I mean if people can't get past having to take a few extra seconds every few weeks for an additional three mouse clicks and will never buy a game because of that... well more power to ya I guess?

    Me?  I'll continue to enjoy playing the game and not getting worked up over something so incredibly trivial.

    In all fairness thats not the issue the OP described. The way i understood it his issue didn't get fixed by restarting the patcher.

  • hotfrosthotfrost TwelloPosts: 20Member
    Originally posted by Rocketeer
    Originally posted by Zyzra

    Yeah when I notice it start to go over the 100% of files, I just close the patcher, relaunch, and play.

    I mean if people can't get past having to take a few extra seconds every few weeks for an additional three mouse clicks and will never buy a game because of that... well more power to ya I guess?

    Me?  I'll continue to enjoy playing the game and not getting worked up over something so incredibly trivial.

    In all fairness thats not the issue the OP described. The way i understood it his issue didn't get fixed by restarting the patcher.

    Yeah I don't really understand what Zyzra is trying to say, I've tried loads and literally LOADS of suggestions.  I've probably already done the first 10 things that will come up in your mind now. 

    I am completely clueless.

    It just doesn't download the last few megabytes, it just stays on 0 bytes/sec forever and sometimes it shows it is downloading with 2mb/sec but it doesn't because not even a single file is being downloaded, even when I left my computer on for the whole night.

  • RaysheRayshe London, ONPosts: 1,284Member
    I've only had the Overdownload issues. Its where the numbers say its done however it keeps going. usually if you close the launcher after it gets to where it should end the game will run fine after.

    Because i can.
    I'm Hopeful For Every Game, Until the Fan Boys Attack My Games. Then the Knives Come Out.
    Logic every gamers worst enemy.

  • OrtwigOrtwig Cambridge, MAPosts: 1,159Member Uncommon
    Originally posted by hotfrost
    Originally posted by Rocketeer
    Originally posted by Zyzra

    Yeah when I notice it start to go over the 100% of files, I just close the patcher, relaunch, and play.

    I mean if people can't get past having to take a few extra seconds every few weeks for an additional three mouse clicks and will never buy a game because of that... well more power to ya I guess?

    Me?  I'll continue to enjoy playing the game and not getting worked up over something so incredibly trivial.

    In all fairness thats not the issue the OP described. The way i understood it his issue didn't get fixed by restarting the patcher.

    Yeah I don't really understand what Zyzra is trying to say, I've tried loads and literally LOADS of suggestions.  I've probably already done the first 10 things that will come up in your mind now. 

    I am completely clueless.

    It just doesn't download the last few megabytes, it just stays on 0 bytes/sec forever and sometimes it shows it is downloading with 2mb/sec but it doesn't because not even a single file is being downloaded, even when I left my computer on for the whole night.

    The mmorpg forums are probably not the best place to get tech support:

    http://www.thesecretworld.com/support

  • aspekxaspekx Brandon, FLPosts: 2,167Member
    aside from relaunching the updater i have found that launching the game with the Window's option to Run as administrator usually keeps it from buggering up.

    "There are at least two kinds of games.
    One could be called finite, the other infinite.
    A finite game is played for the purpose of winning,
    an infinite game for the purpose of continuing play."
    Finite and Infinite Games, James Carse

  • hotfrosthotfrost TwelloPosts: 20Member
    Originally posted by Ortwig

    The mmorpg forums are probably not the best place to get tech support:

    http://www.thesecretworld.com/support

    Not really, I've already had way more replies on this thread than on their tech forums. On the TSW forums I just get totally ignored.

  • RocketeerRocketeer NachrodtPosts: 1,304Member
    Originally posted by hotfrost
    Originally posted by Ortwig

    The mmorpg forums are probably not the best place to get tech support:

    http://www.thesecretworld.com/support

    Not really, I've already had way more replies on this thread than on their tech forums. On the TSW forums I just get totally ignored.

    Did you try the installation on a different machine? Theoretically you don't have to buy the game to install it, so i would just see if it patches ok and then buy it.

    Did you change your machine since the trouble with AoC/beta TSW, or is it the same?

  • OrtwigOrtwig Cambridge, MAPosts: 1,159Member Uncommon
    That link does not go to the tsw forums. It goes to live chat support. As in official.
  • hotfrosthotfrost TwelloPosts: 20Member
    Originally posted by Rocketeer
    Originally posted by hotfrost
    Originally posted by Ortwig

    The mmorpg forums are probably not the best place to get tech support:

    http://www.thesecretworld.com/support

    Not really, I've already had way more replies on this thread than on their tech forums. On the TSW forums I just get totally ignored.

    Did you try the installation on a different machine? Theoretically you don't have to buy the game to install it, so i would just see if it patches ok and then buy it.

    Did you change your machine since the trouble with AoC/beta TSW, or is it the same?

    Yes I have tried installing it on another machine and it didn't work. I didn't change machines only got a extra machine(macbook) and tried it on there, no luck. 

  • SiugSiug TallinnPosts: 1,236Member Uncommon
    Originally posted by hotfrost
    Originally posted by Rocketeer
    Originally posted by hotfrost
    Originally posted by Ortwig

    The mmorpg forums are probably not the best place to get tech support:

    http://www.thesecretworld.com/support

    Not really, I've already had way more replies on this thread than on their tech forums. On the TSW forums I just get totally ignored.

    Did you try the installation on a different machine? Theoretically you don't have to buy the game to install it, so i would just see if it patches ok and then buy it.

    Did you change your machine since the trouble with AoC/beta TSW, or is it the same?

    Yes I have tried installing it on another machine and it didn't work. I didn't change machines only got a extra machine(macbook) and tried it on there, no luck. 

    I remember when I first installed TSW my anti-virus program caused the same issue. Used Kaspersky back then and had to turn it off when patching the game.

«1
Sign In or Register to comment.