Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can't sign up

brad31781brad31781 Charlotte, NCMember Posts: 54

So odd I haven't been able to sign up all day and I've seen other sites showing this same problem since early this morning. Wonder if they even know? I have had no one make an account in the past 24 hours at this IP or even in this house.



  • DragimDragim Boring, KSMember Posts: 867 Uncommon

    Wierd, I made an account the other day...

    You are on the wakfu website..the english website, correct?

    Not sure how else to describe what to do than to go to the website and click sign-up!

    Though the free-to-play is a bit limited, it is only 6$ a month to sign up!

    Good luck though hopefully you can get through and make an account.

    I am entitled to my opinions, misspellings, and grammatical errors.

  • brad31781brad31781 Charlotte, NCMember Posts: 54

    I have tried these 2 websites and clicking the 'Create an Account' option at the top right.


    After filling in the boxes on both sites and clicking register nothing  happens, if you click register again you get the message "Fields are empty or invalid". All boxes have green borders like they are filled in correct.


    Was going to try the free portion before making a decision on whether to pay or not, as I'd get a feel for the combat that would be something I haven't experienced before.

  • RidelynnRidelynn Fresno, CAMember Posts: 5,245 Rare

    It's broke for me too. First time I click, it looks like it's doing something then stops. I click it again, it tells me that something is invalid or blank, but nothing is (or if it is invalid, it isn't telling me what). I tried a couple of different usernames and emails, so idk what the problem is. I tried sniffing around on their support site, but couldn't find anything meaningful and couldn't find a link to directly contact their support.

    Maybe I'm pre-banned ^.^

    Oh well - game looked neat, I wanted to check it out.

  • RidelynnRidelynn Fresno, CAMember Posts: 5,245 Rare

    Ok, I found the support page.

    But get this....

    I can't submit a ticket without a valid account name.

    I guess I am just stuck.

    Maybe someone with an account can post it on their forums or something.

  • brad31781brad31781 Charlotte, NCMember Posts: 54

    A thread is up on their website now, you can view it here:

    and here:


    I can't tell time zone (since I don't have an account) but it appears the first one was was made about an hour ago+

  • brad31781brad31781 Charlotte, NCMember Posts: 54

    This is now fixed. I was able to make an account an hour or so ago.


    Sadly the game I don't think is for me. It is quite confusing for a beginner and I had trouble locating any help on the forums or in game. It looks nice though =)

  • RidelynnRidelynn Fresno, CAMember Posts: 5,245 Rare

    Ok just tried this again after seeing that it may work.

    Still didn't work on my computer - same error (Fields are missing or invalid), so I tried it over my phone: it let me create an account, but the human verification kept failing (pretty sure I was getting it right). After 3 attempts it kicked me out, and I can't get back.

    Apparently it went through, because it won't let me try to re-register with the same username or account name, but no registration email. Trying to log in fails saying the account is invalid, and of course I can't try to just create another account for another 24 hours.

    Tried tethering my phone to the computer, same error (Fields are missing or invalid), but it let me go through at least that step on the phone's web browser...

    All in all, too bad. This game has now become too much trouble to be worth my time. Actually, it was probably past that point a while ago, but I saw it as kind of a physical challenge. Apparently a broken registration and support system is more powerful than my will to try this game.


    Via the magic of tethering, and finding this post on their forums:

    and trying to register directly through this URL

    I did get it to finally work.

    I guess I can finally beat the game after all. Oh wait, you mean that wasn't the game?

Sign In or Register to comment.