Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

My experience with 9Dragons

PeckyDOOMPeckyDOOM Bellflower, CAPosts: 16Member

So after a long time of reading the forums checking out screenshots and just critally balancing out the pro's and con's of the game and figure its worth the download.

Im working on a semi-busy wireless internet connection ( wireless N-signal, at 280/kbs download) so it took about 40-50 minutes to complete the download and patching.

Prior to the download i signed up for the the acclaim user account. That was quick and easy. So no problems there.

Now the bad part. So started up the game and noticed immidiatly how the screen flickered everytime i clicked on a button. then when i started to build my character the character kept flattening out and then apperaing and kept flickering. I shrugged it off and just proceeded assuming maybe its just a menu glich i can report later on.

then when i began to play to my dissapointment the tree's grass NPC and of course my character was flickering like crazy. it was quite distracting and very un-appealing. after scouring the forums on the acclaim site and not finding answers. i just gave up and un-installed.

If anyone has a solution or a simular problem please share.

Tagged:

Comments

  • TrashcantoyTrashcantoy DragonstonePosts: 827Member

    99 % of the time its your graphics drivers, update them but downgrade may also help sometimes

    random dcing and crashes are standard here BUT acclaim is working on fixes through the community

    MMOs currently playing: -
    About to play: Lord of the Rings Online
    Played: Anarchy Online (alltime favorite) and lots of f2p titles (honorable mentions: 9Dragons, Martial Heroes, Dekaron, Atlantica Online)

  • LimonesLimones gofuckyourselvesPosts: 95Member

    What you're experiencing is not normal. I'm a big fan of 9Dragons and I've been playing it for a few months now but the only thing I've encountered so far are random dc's and some lag now and then. So like the guy above me suggest: check your drivers and try again. It's worth it...

Sign In or Register to comment.